Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-30-2007, 02:50 PM
Registered User
 
Join Date: Sep 2007
Posts: 1
W124 Stumble & Intermittent Check Engine Light

A 1988 300E stumbles badly every time the check engine light comes on. Light comes on at any speed and any engine temperature. It usually pulses for a second or less but sometimes will flicker for several seconds. If it stays on the engine ceases to run. It will always restart after it kills. I have replaced the fuel relay, overload protection relay, oxygen sensor, and fuel filter since the symptoms developed one month ago. What else turns the check engine light on besides the O2 sensor? The engine has a CIS-E fuel delivery system. When it runs without a light it runs very smoothly except at prolonged idle where it will start to miss after 3-4 minutes of idling.

Reply With Quote
  #2  
Old 09-30-2007, 08:07 PM
190eand me's Avatar
Registered User
 
Join Date: Aug 2007
Posts: 55
wiring

you have a short in the wiring somewhere....from the sound its in one of the sensor circuits.....look for broken wire insulation around the connectors (wire)
thats where i would start.
Reply With Quote
  #3  
Old 10-01-2007, 01:25 AM
92 400E,87 300SDL,67 230
 
Join Date: Jul 2005
Posts: 56
Quote:
Originally Posted by Smiley1 View Post
A 1988 300E stumbles badly every time the check engine light comes on. Light comes on at any speed and any engine temperature. It usually pulses for a second or less but sometimes will flicker for several seconds. If it stays on the engine ceases to run. It will always restart after it kills. I have replaced the fuel relay, overload protection relay, oxygen sensor, and fuel filter since the symptoms developed one month ago. What else turns the check engine light on besides the O2 sensor? The engine has a CIS-E fuel delivery system. When it runs without a light it runs very smoothly except at prolonged idle where it will start to miss after 3-4 minutes of idling.
If the check engine light is on, it should set a code. jim Forgione has a really helpful website at http://pages.prodigy.net/jforgione/MB_S500.html with a schematic of a code reader you can make for $15 or so at the bottom of his page at
http://pages.prodigy.net/jforgione/MB_X11.html

If you get the codes for the various systems, the code book can be had for free from Steve Nervig's website at http://web.mac.com/dakota/Mercedes/Indexes.html. Download his Service Library for a ton of great stuff.

Once you know the codes, you can figure out what to fix!

Gerry

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page