PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   300te front end clunking... (http://www.peachparts.com/shopforum/tech-help/203037-300te-front-end-clunking.html)

Eliot 10-21-2007 06:02 PM

300te front end clunking...
 
1989 300te....I get clunking in the front end over small bumps, uneven roads. New front struts did not change the problem. However, the mechanic did NOT put in new upper strut bearing (is that what they are called?). I can see cracks in the rubber of the upper strut thing as viewed looking down at it in the engine compartment. As you bounce on the bumper, the crack will open slightly...no clunking.
Under the car, I was playing with the sway bar, grabbing it, jerking on it. It is 'loose' in the rubber mounts that connect it to the body (not the wheel assembly). The rubber mounts do not close tightly on the sway bar, about 1/16" - 1/8" space around the bar. Is that 'normal'? Are the sway bars supposed to be 'captured' by the rubber mounts, or left to have some play?

Pete Geither 10-21-2007 07:04 PM

Get the sway bar bushings,,, most probably will take care of the problem. Very common on 124s.


All times are GMT -4. The time now is 04:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website