Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2007, 04:01 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Still having a Key issue - 2001 E430

Every once in a while, my key won't unlock the doors. After a few tries, it works. Other times, the key unlocks the door. I insert the key, the car recognizes the key (I hear the click), I turn the key, the engine bumps for a fraction of a second, the nothing.

Once this happens, I have to turn and hold the key in the start position for a few seconds. The car then starts, but the ESP light comes on and the display tells me the car needs service. I turn the car off immediately, and it will restart right away, and the warnings are gone and everything is ok.

This happens with both keys. Any ideas? I don't think it is the keys. Something in ESP?
__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
  #2  
Old 11-04-2007, 12:30 PM
Benz300's Avatar
Benz Enthusiast
 
Join Date: Sep 2003
Posts: 803
is this a different key ? when you unlock, are you using the buttons to unlock ? it could very well be that the key is out of sync. have u tried using the other key that came with the car ? what happens when you do that ?
__________________
Whether you think you can or cannot, Either way you're right!. by Henry Ford.
Reply With Quote
  #3  
Old 11-04-2007, 12:38 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
One key looks original (old), one looks very new, and a third is brand new. They all seem to do the same thing. I use the original most of the time, figuring it will eventually go south first.
__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
  #4  
Old 11-04-2007, 04:06 PM
whunter's Avatar
Moderator
 
Join Date: Dec 2003
Location: Metro Detroit, Michigan
Posts: 17,354
Answer:

Best guess:
The security module is going bad.
Reply With Quote
  #5  
Old 02-05-2008, 10:19 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Since posting this, I have exclusively used the new key. Now the doors unlock and lock as they should.

But every once in a while, the esp/bas will fault with a yellow light and the center display ordering me to go to get serviced. If I turn the engine off and restart it, everything is fine. I bought a second new key as well (the Chrome new key looks nice, eh?), and it does the same thing.

Any clues? I just hate to bring this to a dealer - I can imaginespending thousands in electronic modules and never getting it fixed competely anyway.
__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page