Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-07-2007, 06:36 PM
arto
 
Join Date: Oct 2007
Location: Calgary
Posts: 3
300 CD vacuum problems

1984 300 CD no power brakes and unable to shut off. On again off again problem.

checked the vacuum hose connections by the oil filter as had the shut off problem berfore.
Reply With Quote
  #2  
Old 11-07-2007, 09:31 PM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,107
It might be time to rebuild the vacuum pump. Search the Diesel archives.
Gently pull off one of the hose by the brake booster line - see if you have any vacuum there. If you don't, there is a rebuild kit, and after 1/2 a day, you will be stopping and locking your doors again.

If the vacuum loss is intermittant, it could be a check valve(s) going bad (they are insided the vacuum pump)
__________________
It is a truism that almost any sect, cult, or religion will legislate its creed into law if it acquires the political power to do so. Robert A. Heinlein


09 Jetta TDI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page