Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-08-2001, 06:30 AM
Posts: n/a
Hello all,

Just had my transmission (722.3) in my 280E repaired,
it had broken the rear band.
Is this a common failure in these transmissions?
The B2 piston was of the later type too.

Should I be paranoid and not drive too far from home?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
transmission slip reverse 722.4 bgarvey Tech Help 2 02-23-2005 12:39 AM
Rear end low & front end high. Advise needed mikaelw2001 Tech Help 1 02-12-2003 04:37 PM
W126 transmission or rear differential noise 420 Tech Help 5 04-09-2002 11:58 PM
722.3 transmission problem jeffsr Tech Help 13 01-09-2002 03:58 PM
Leak from rear of transmission. Pan Gasket? Steve190E 2.3 Tech Help 2 04-10-2001 01:50 AM

All times are GMT -4. The time now is 04:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page