Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-10-2001, 01:03 AM
Registered User
 
Join Date: Mar 2001
Location: N. California
Posts: 28
I just purchased 1988 560 sel with 136,000 miles, the nitrogen cells were replaced 2 years and 20,000 miles ago. It rides over little bumps like there is 150 lbs air in the tires. I want the car to have a soft smooth ride and not into performance handling, any suggestion, is this normal, how do I make it ride smooth. Thanks
Reply With Quote
  #2  
Old 07-10-2001, 09:15 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
It still sounds like accumulator problems. If you are feeling the harsh hide thats the answer. If you are hearing it instead, I would look to the upper strut bushings in the rear. During the time the cells were bad they took a terrible beating.

I would suggest to bring it by cause I could tell you in a five minute road test, but there are others much closer I assume. An experienced MB tech will know the condition. The other alternative is to test. If you are paying for it the test will cost as much as one (or more) of the accumulators.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing all shifter bushings on W126 - p.1 rurik Diesel Discussion 22 04-13-2012 04:41 PM
W126 Ride quality jammer Tech Help 16 05-13-2005 06:58 PM
1991 W126 Radiator Replacement bisric Diesel Discussion 3 04-22-2004 03:38 PM
W126 Hydropnuematic suspension? Rick Hesek Tech Help 10 03-08-2004 11:02 AM
ride on w126 560sel? stanigu Tech Help 1 11-18-2003 05:34 PM



All times are GMT -4. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page