Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-11-2001, 11:48 AM
Posts: n/a
My '85 300D has been blowing aux fan fuses. I replaced the fuse (16a) and the fan runs, but now the fan just doesn't come on. I saw the trick with grounding the temp switch wire to make the fan come on, but my question is:

Was the temp switch potentially causing the blown fuse or should I be looking at replacing the fan motor (or relay) to really fix the problem????

Reply With Quote
Old 07-11-2001, 04:46 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Rusty the switch is only a trigger for the RELAY that controls the motor. THE only thing that should blow the fuse is the MOTOR itself.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 07-12-2001, 09:39 AM
Posts: n/a
Remove the battery and/or windshield was reservoir and check the wires leading from the fuse bosx to the fan. I had a similar problem in my '76 230 and found out that the wire (down around the headlamp area) was frayed and chewed out (from what I don't know, an animal maybe or just rust) and then I cut out the bad parts, spliced the wire and used butt connectors to re-attach the wire, so it was'nt exposed. This worked fine.

Good luck,


1976 230.4 W115
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
M119 Viscous Fan mod & problems with aux. fan resistor-mod ke6dcj Performance Paddock 92 05-19-2010 10:36 AM
DIY Notes may help people: Radiator, Fan Clutch, Temp Sensors, Fuel Pump, Temp Gauge ericgr SL Forum 3 09-24-2004 01:40 AM
560sel Aux Fan - A/C Problem moedip Tech Help 27 07-09-2003 11:31 AM
aux. fan, mods and testing coachgeo Diesel Discussion 14 07-02-2003 12:14 AM
aux fan, etc. JHZR2 Diesel Discussion 4 04-18-2002 07:15 PM

All times are GMT -4. The time now is 12:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page