Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-17-2001, 10:48 AM
The Bob
Posts: n/a
Hello all,

I thought that my climate control blues were behind me when my dashboard starting smoking today. I quickly pulled out my climate control unit and there was a nice burnt hole in it. I heard that my auxillary water pump might be drawing too much power. Where is the auxillary water pump and how hard is it to change. Also what is the likelyhood of it being my monovalve.

Thanks for all your help.

I did not brake it this time.

Reply With Quote
Old 07-17-2001, 12:06 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
What car? Usually below and slightly forward of expansion tank. Monovalve is usually in the battery compartment. Follow the hose from the aux water pump..
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
Old 07-17-2001, 01:22 PM
The Bob
Posts: n/a
Thanks for the reply

It is a 84 300d. Should I replace it? Is it hard to replace. I am glad that my climate control unit had a warranty on it.


Reply With Quote
Old 07-17-2001, 02:10 PM
RunningTooHot's Avatar
Registered User
Join Date: Aug 2000
Location: Here
Posts: 775
Please donít shoot the messenger, but you may find that the warranty on electrical items is a bit tenuous. Get ready for a fight if you were the one that installed it.

As far as the pump, it is a piece of cake on your model. It is located on the passenger side on the inner fender well. The mono valve is on the firewall on the 123s. It is best to properly diagnose the problem Ė find out what is wrong before you throw parts at it.

Reply With Quote
Old 07-17-2001, 02:22 PM
Posts: n/a
It's over when the fat lady sings

Brother of The Benz, The Bob
Should the aux water pump fail on my 1987 300E, the MB Service Technican said I could by-pass it and experience no change in the heater performance.
Ofcourse I live on the Gulf Coast and it doesn't get very cold.
Not so on the mono-valve, you should check into it.
I don't understand your discription of where the damage was caused.
I gather it is on the inside of your Benz, in the A/C housing. If so, how could these two items being under the hood effect the housing? And what effect could the aux-pump draughing too much current and not opening a fuse burn a hole?
Do some diagnosing before you wholesale replace parts.
It must be silly ole me.
Happy Trails Beep Beep from The Spiderman in Houston!!!
Reply With Quote
Old 07-18-2001, 02:10 AM
The Bob
Posts: n/a
Thanks guys for the replies,

I should have no problem with the part return as my brother works parts at the dealer. Only problem is that he is slow to do favors but is another story.

I dont know exactly how I burned a quarter sized hole in my climate control unit. I heard that the auxillary water pump if drawing too much could cause that. When it blew up I was in the mid range tempurature setting so the auxillary water pump might have been used. I dont know for sure, I will Volt test the pump soon.

thanks for your help,

Reply With Quote
Old 07-18-2001, 02:28 AM
Registered User
Join Date: Oct 1999
Location: New York City Burbs
Posts: 177
I too have had bad experiences with the aux water pump on my 84 190E. Okay, parts wear out, but when the replacements are consistently bad, I get annoyed. (But since I have owned a slew of British roadsters, I am used to it)
Patrick Leber
'84 190E 2.3
'83 Porsche 944 (track car)
'84 Porsche 944 (parts car)
85.5 Porsche 944 (sled)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300E leaking coolant near water pump mike690003 Tech Help 4 08-04-2003 07:30 AM
84 380sl augsilary water pump litletrees Tech Help 0 09-17-2002 08:43 PM
616 engine water pump replacement kerry Diesel Discussion 4 07-20-2002 10:38 AM
Water Pump Noise?? Please help!! stummala Tech Help 13 02-15-2002 05:32 PM
aux. water pump & mono valve questions TheLaw Tech Help 1 08-23-2001 10:01 PM

All times are GMT -4. The time now is 02:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page