Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-22-2001, 09:34 PM
Registered User
Join Date: Feb 2000
Location: Simpsonville, South Carolina
Posts: 77
My 1999 E300D AC with 52k miles stopped Saturday. The Climate control was working in the auto mode when I punched the recirculate button to remove cabin odors. A couple of minutes later and the AC stopped working and the EC (economy) light came on and the compressor stopped. I am almost positive I did not touch the EC button. I can not get the EC light to go off so the compressor will come back on. Any suggestion's would be appreciated and comment if Mercedes will pick up the bill. Mercedes had the control unit out of the car at about 35K because of a temp problem. Thanks for your suggestions.

Reply With Quote
Old 07-22-2001, 10:17 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
If you have a good dealer, then I'm sure they would pick up the bill.
But for the time being... your compressor has obviously had something happen, thus the EC light telling you the compressor is not active.
Retrieve some codes and report them back here....

Turn the the ignition to position 2 (all the way over, but with car off), put both sides on AUTO, set the left side to HI and the passenger side to LO. Press and hold the REST and (front) DEFROST buttons at the same time for about 5 seconds... the system should shut off and read DIa. (for diagnostics). Press the driver's side AUTO button to scroll through the codes, record them as you go.

GOod luck, some people have trouble with this, but I believe I have given you accurate directions on how to get this info from your model.
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 C43 - A/C Blower Question - Issue 99C43 Tech Help 3 10-06-2004 01:06 PM
'84 300SD W126 - A/C Question - the saga continues bodyart27 Diesel Discussion 13 06-23-2003 05:32 PM
A/C on and my car is boiling hot?? Holson Adi Diesel Discussion 5 05-25-2002 06:03 PM
1999 E300 Turbodiesel kwmccauley Mercedes Used Parts For Sale & Wanted 1 01-24-2001 06:09 AM
1999 E300 Turbodiesel Mustafa Ahmed Tech Help 7 05-01-1999 12:24 PM

All times are GMT -4. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page