PeachParts Mercedes ShopForum

PeachParts Mercedes ShopForum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   89 560 sel (http://www.peachparts.com/shopforum/tech-help/21177-89-560-sel.html)

benz560sel 07-25-2001 09:54 PM

I got a few problems with my 1989 560 SEL, 98,000 miles. My auxillary fan seems to kick in whenever my temperature needle hits the middle. Sometimes, after my car has cooled down from a drive, i will start up the car, without kicking in the ignition, and the auxillary fan will come on spinning. I understand the auxillary fan should turn on when the engine gets very hot, however, it shouldn't be hot enough but it comes on, even during winter time. My mechanic says it could be the relay, which he checked and said it wasn't. he can't seem to figure it out. I replaced the radiator already. Any solutions?

also, the back seems to sag a little, or in other words, is lower than the front by quite a bit that you can realize it. i replaced the rear shocks and hydraulics since it was giving me a very bouncy ride in the rear. the back is still sagging a little bit lower than it should be. my mechanic says that changing the springs isn't going to make it higher in the rear to even up with the front. he also says that it's very difficult to change the rear springs on that car because he has to remove the differentiator. should i invest in changing the rear springs? it cost me quite a bit of money changing the shocks and hydraulics, i'm guessing the old springs in there is going to wear out the expensive shocks and hydraulics a lot faster. any ideas?


one more question, when i park my car, stop it at a parking spot, and put the gear in P, my car rolls back quite noticeably. any fixes for that?
also, do i need an alignment done after changing those shocks and hydraulics?

stevebfl 07-25-2001 10:13 PM

The aux cooling fan usually comes on first for A/C reasons. If the A/C is off and the car has just started and the fan is on then yes you probably have a relay problem. Get a wiring diagram and check it out. Your tech should not have problems with testing this.

Did you replace the accumulators on your suspension. These are the cause of most leveling system problems. If you are low in the rear then the system is not pumped up. Again your tech should be able to diagnose these problems or you might look for another.

The system will level the car if it is working properly. It will make up for weak springs as it will a heavy load. Thats the point. There are no alignment adjustments in the rear suspension. It should be in alignment when the car is at the right height. Getting the ride height right doesn't necessarily require testing alignment.

MB has very large dogs on their parking pawl. This means that they will roll much further than most trannies before they catch. They should not miss a tooth though. There are conditions where the pawl skips or misses a tooth. A simple evaluation by an experienced tech should be all thats needed to verify either condition.

benz560sel 07-25-2001 10:22 PM

one more question...
 
How much are accumulators? How much labor should i be charged for those? Do you recommend changing the springs since the car already has 99,000 miles? thanks for your help.

benz560sel 07-25-2001 10:24 PM

also
 
the A/C is off and the car has just started and the fan is on and it's not a relay problem as my tech has replaced the relay with a new one, and still has the same problem. just seems to come on when the car gets hot, but the car doesn't get hot enough for reason that the aux fan should come on. hmmm....thanks again.


All times are GMT -4. The time now is 10:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website