PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Weird electrical issue 88 300 SEL (http://www.peachparts.com/shopforum/tech-help/212404-weird-electrical-issue-88-300-sel.html)

ericzacha 01-31-2008 03:36 PM

Weird electrical issue 88 300 SEL
 
My fuel pump and relay went out. I didn't have time to fix it myself, so I took it to the local indy I trust. Fixed it and had it back to me within the day. But when I got home I had a weird electrical issue. When I turn off the ignition the radio doesn't go off. It stays on until I open and then close the door, even with the key out. Even more odd to me, the radio kicks on when I open the door back up, even with the key out of the ignition. When I close the door again it goes off. I replaced my becker about a month ago with a new alpine. Ran all new wires to the speakers and bypassed the amps. But I hadn't had this or any problems since installation. The only electrical thing my mechanic did was to replace the fuel pump relay. Anyone have any thoughts?

I also notice that when I open the door the SRS light comes on. I hadn't noticed that before, maybe I just never paid attention. Anyone with a w126 want to tell me if their SRS light comes on when you open the door?

ericzacha 01-31-2008 03:42 PM

I should add that I used the Crutchfield wire harness and followed several posts related to wire colors, so everything should be hooked up to the radio correctly. I really don't think I hooked the radio up wrong, it worked just fine for over a month.

ericzacha 02-01-2008 11:19 PM

The mechanic told me that I had the incorrect fuel pump relay on the car. He replaced it with the correct one. Is it possible that changing to a different fuel pump relay caused this?

Xsbank 02-02-2008 02:27 AM

Check the part number on the new relay.

Unusual that it should start right after service...

Its possible that you have the wires confused on the new radio - power wire connected to the 'lighting' wire?

ericzacha 02-02-2008 02:52 AM

So my old part number was 0025455205. This was evidently superseded by part number 0035452405 which is what was put in my car. The original was a nine pin and the new one is a ten pin. It seems like Mercedes has done this with a couple of different relays, where the new part has an extra pin. Anyone know why they keep adding the extra pins? Could this somehow have affected my radio? I know I'm eventually going to have to take the radio out and check the wires, but it was just such a pain in the butt the first time. Somehow the radio is now hooked in with the interior lights, but how could I have hooked into one of those wires. Those shouldn't really live behind the radio or have been hooked up to the old radio.

Hit Man X 02-02-2008 05:46 AM

Disconnect the radio and go from there. Hell, you could even just pull the fuse to eliminate it from the system.

Do the same for the fuel pump relay.

stevebfl 02-02-2008 01:39 PM

Try pulling the separation diode for the seats.

ericzacha 02-02-2008 06:12 PM

Where is the separation diode located?

stevebfl 02-02-2008 06:18 PM

Next to the power seat relay oin the fuse box.

ericzacha 02-02-2008 07:05 PM

Steve,
You're a genius! I have read many of your posts in the past and am always impressed. So I pulled the gray two pin relay next to the power seat relay. It was marked "G". Opened the door, and sure enough, no radio. Put the key in the ignition and the radio worked just fine. Interior lights seem to work normally. I tested the power seats and they seem to work fine.
So now I beg of you Oz, what's behind the curtain? How did you know to pull the separation diode? What does the separation diode do? Will it cause some sort of problem if I leave it out? If I am lacking some sort of functionality, I have been unable to find it. Any thoughts as to why the installation of a ten pin fuel pump relay caused the separation diode to turn my radio on? Sorry so many questions, but I am befuddled.

stevebfl 02-02-2008 07:39 PM

Pretty simple relationship really. The key elements are the door and the ignition off. The diode allows power to the seat when the door is open without the key on. It separates the normal key on operation. Without the diode you won't be able to move the seat with the door open and the key off.

Not sure how the diode issue occured with the relay. Leave it out till you verify that is the only issue and then replace it. It is probably shorted (conductive in both directions)

Xsbank 02-02-2008 09:51 PM

Clever! Nice solution! Learn something new every day....

ericzacha 02-04-2008 04:15 PM

So I cracked open the separation diode today. It was burnt. New one is ordered. Thanks Steve and everyone else who threw in their two cents.


All times are GMT -4. The time now is 03:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website