Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-07-2008, 11:12 PM
Registered User
 
Join Date: Feb 2008
Posts: 223
2002 C240 Tranny Problem!!!!!!!!!help

My car will not shift out of first gear, also it will not shift over where I can manually shift gears from drive with my slap stick gear shifter? When I shift out of part into reverse or drive it goes into gear violently. I am pretty handy and got a rebuilt transmission and installed it but the problem is still happening. Anyone have any idea what it could be?
Reply With Quote
  #2  
Old 02-07-2008, 11:13 PM
Registered User
 
Join Date: Jul 2003
Location: St. Louis
Posts: 43
The shifter is most likely your problem. Did you get it wet right before the problem happened?
Reply With Quote
  #3  
Old 02-07-2008, 11:15 PM
Registered User
 
Join Date: Jan 2008
Posts: 5
your trans is in limp mode. codes need to be cleared or you may have a problem with module.
Reply With Quote
  #4  
Old 02-07-2008, 11:38 PM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
Did you really replace the transmission without checking fault codes first???

I agree with above, it sounds like a bad shifter module.
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #5  
Old 02-08-2008, 08:20 AM
Registered User
 
Join Date: Feb 2008
Posts: 223
I had car checked for codes today by a friend and my car has a code in it P0702 transmission electrical system malfunction or something to that nature. Does that narrow it down for anyone out there? What kind of job is the shifter module that seems to be my problem from the feedback I am getting? Thanks alot.
Reply With Quote
  #6  
Old 02-08-2008, 12:16 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,554
Before you waste any more money, check to see if the transmission control module is full of ATF.
Reply With Quote
  #7  
Old 02-08-2008, 11:02 PM
Registered User
 
Join Date: Feb 2008
Posts: 223
I have replaced the transmission control module.
Reply With Quote
  #8  
Old 02-08-2008, 11:05 PM
Registered User
 
Join Date: Feb 2008
Posts: 223
I replaced the transmission because when I pulled the pan off there was lots of shavings in the pan. Do I need to have the computer reset now? Does the code stay in the system, could I have fixed the problem and the code still be in the car's computer?
Reply With Quote
  #9  
Old 02-08-2008, 11:18 PM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
yes, reset the codes and reset shift adaptations as well.
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
  #10  
Old 02-09-2008, 04:34 AM
C32AMG's Avatar
Registered User
 
Join Date: Mar 2004
Location: new york/orange county
Posts: 639
Quote:
Originally Posted by BigRed0803 View Post
I have replaced the transmission control module.

Did you buy a new coded TCM for your vehicle and transmission, used TCM will not work unless coded.
__________________
Steve Cattaneo www.mastertechtrans.com


03 SL500
02 MB AMG
87 560 SEC
87 300D
928S 83
85 928 S2 EURO
Reply With Quote
  #11  
Old 02-09-2008, 07:39 AM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,554
Quote:
Originally Posted by BigRed0803 View Post
I replaced the transmission because when I pulled the pan off there was lots of shavings in the pan.
Did you flush the transmission cooler? If there were metal shavings in the pan, you can be sure there's some in the cooler as well.
Reply With Quote
  #12  
Old 02-09-2008, 12:40 PM
Johnhef's Avatar
Senior Member
 
Join Date: Feb 2005
Location: Frederick, Md
Posts: 4,540
same goes for the torque converter- was it replaced?
__________________


1980 500SE/AMG Euro
1981 500SEL Euro
1982 380SEL
1983 300TD
1983 500SEC/AMG Euro
1984 500SEC
1984 300TD Euro
1986 190E 2.3-16
1986 190E 2.3
1987 300D
1997 C36 AMG
2003 C320T 4matic

past: 1969 280SE 4.5 | 1978 240D | 1978 300D | 1981 300SD | 1981 300SD | 1982 300CD | 1983 300CD | 1983 300SD | 1983 380SEC | 1984 300D | 1984 300D | 1984 300TD | 1984 500SEL | 1984 300SD | 1985 300D | 1986 300E | 1986 560SEL | 1986 560SEL/Carat | 1987 560SEC | 1991 300D 2.5 | 2006 R350
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page