Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-11-2008, 12:02 PM
Andy_M's Avatar
Andy_M
 
Join Date: Jul 2007
Location: Northwest NJ
Posts: 132
1990 E300 flat spot in throttle response

My '90 300E idles fine, runs well, and doesn't seem to get bad mileage, but has a distinct flat spot on initial acceleration off idle if not in 1st gear. If I kick it down it takes off like a shot, but unless you kick it down it dogs along. Other than this it runs smooth as silk and good as can be.

My daughter (who is quite mechanically astute) has also commented that the car smells rich when you are driving behind it.

Time to have the FI adjusted ?

__________________
Andy_M
'98 W140 S320 Black/Black
'06 W164 ML500 AMG White/Grey
'03 Porsche 986 Midnight Blue/Grey
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page