Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2008, 01:15 PM
Rahulio1989300E's Avatar
V10s & V8s FTW!
 
Join Date: Jan 2005
Posts: 1,141
Gas smell, Idle hunting... CRAP!

Hello,

203,000 mile M103 in my 1989 300E.

This morning I was at a stop light about 2 blocks from my house, on North Ave. (ATL people...)

Engine starts to hunt for idle. My foot is on the break, no gas input. Idle runs between 750 and 550. Just goes up and down. Then the light turns green and I get onto I75. Car performs fine, no performance issues, same amount of power as normal.

Then, at about 11:15 I leave for lunch. Car start just fine, everything is normal. I get to lunch, eat, leave and get back to the office.

I pop the hood to do a quick look around. (I do this like every 3 days. Either back from lunch or when I get home.)

I am greeted with a very strong gasoline smell. I am freaking out. I have a feeling I am going to die today in a flaming ball of German fire...

I am at work and my lunch time ends in 50 seconds. I do not have time to search the forums for clues. If anyone can at least give me a link or suggestion I would be very thankful as I do not want to burn.

Thank You!
__________________
2006 BMW M5 "Heidi" @ 96,000 miles
2005 MBZ C55 AMG "Lorelai" @ 120,000 miles
1990 MBZ 500SL "Shoshanna" @ 118,000 miles
Reply With Quote
  #2  
Old 03-25-2008, 07:51 PM
Rahulio1989300E's Avatar
V10s & V8s FTW!
 
Join Date: Jan 2005
Posts: 1,141
Okay, there is most likely, unless I have the placebo effect going a reduction in off the line performance. Car feels a bit sluggish when taking off from idle.

Fuel smell is still present.
__________________
2006 BMW M5 "Heidi" @ 96,000 miles
2005 MBZ C55 AMG "Lorelai" @ 120,000 miles
1990 MBZ 500SL "Shoshanna" @ 118,000 miles
Reply With Quote
  #3  
Old 03-25-2008, 11:10 PM
Rahulio1989300E's Avatar
V10s & V8s FTW!
 
Join Date: Jan 2005
Posts: 1,141
Okay, I took off the air cleaner today and found that the bottom of the EHA valve at the back of the fuel distributor is wet. Fluid (gas) matched the smell I detected from the car earlier.

Could it be possible that one of the two rings has sprung a leak? Or do you think the entire EHA is leaking?

Anyone got a non-leaky used one they want to sell me? Its a bit expensive new...
__________________
2006 BMW M5 "Heidi" @ 96,000 miles
2005 MBZ C55 AMG "Lorelai" @ 120,000 miles
1990 MBZ 500SL "Shoshanna" @ 118,000 miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page