Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2008, 09:59 PM
Registered User
 
Join Date: Mar 2008
Posts: 1
300E Air Conditioning

I have a 1990 300E, the ac was only working when the car was moving at a decent rate. Now the ac won't blow at all. It sounds like it is trying but not making it. Not quite sure where the issue is and how to resolve it.

Reply With Quote
  #2  
Old 03-26-2008, 06:56 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,353
Sounds like your fan or fan controller is shot.

It's under the wiper mechanism.

Jim

__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page