Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2001, 02:33 PM
Tundra45
Guest
 
Posts: n/a
Unhappy '77 300D w123 heat/ac probs and aux fan

Should I shoot it in the head, pull the saddle off and walk out?

First problem- hot water continuously flowed into heater core and system blew hot air regardless of t-stat setting

Second problem- no hot water in core and no heat blowing even when t-stat is at highest setting

Current problem- no heat and the dash fan stopped working

A "technician" swapped out the amplifier and dash controls w/out success and put old ones back; charged me up and still have probs.

Question 1: Does the climate control servo (mucho $) control any/all of the features that may be malfunctioning?

Question 2: The auxillary fan on the radiator doesn't come on. Could the servo affect its operation as well?

Last edited by Tundra45; 08-10-2001 at 11:00 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page