Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-11-2001, 09:07 AM
Mark Elrod
Posts: n/a
ML 320, Stuff Running?

Well...My wife has traded her SDL for an 1998 ML 320. Now I get to figure it out and need some help.
When the engine is shut-off, there is a cooling fan in the electrical box that continues to run for several minutes, the aux. water pump also runs for the same time. Is this normal? Is something overheating? What is the issue and is it something I need to persue?

Also, basing this on the excellent guidance my other requests received, the "master Lock" system on this truck works from the console button, but not with the drivers door key or the remote.
Any paericular place to start running this problem down.

Many thanks in advance.
Reply With Quote
Old 08-11-2001, 09:23 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The aux water pump is designed to run for upto 10 minutes every time the car is shut off, but you aren't supposed to HEAR it. Should be Quiet.
THE key problem on 1998 TRUCKS has been a source of 2 different service campaigns. Make sure that this truck has the latest version AAM modification, which includes all new keys!! & the computer that controls the locking system.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 C280 Temperature running higher. Ionman Tech Help 12 04-05-2011 01:02 PM
190e running rich with eha on/off.Bad mpg.Help! azhari Tech Help 85 07-15-2007 07:37 PM
Running Hotter Than Normal chrisalex78 Diesel Discussion 19 11-04-2003 10:26 PM
1987 190E 2.6 Running Rich?? arnelrac Performance Paddock 3 02-27-2002 01:17 PM
1986 Euro 190E 2.3-16 Suddenly Running Really Rough - Any Suggestions? JimSmith Tech Help 2 02-15-2002 09:56 PM

All times are GMT -4. The time now is 08:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page