Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-17-2001, 12:03 PM
Registered User
Join Date: Apr 1999
Posts: 2,632
W124 Speedo Cable

Is there some special "art" or "black magic" in replacing the speedo cable so that the center portion doesn't rub against the cable-walls thus causing a rubbing/vibration sound? I've tried to stay away from sharp turns when laying in the cable, but it's been frustrating to hear it at 65+ mph and above.

Thanks in advance,
:-) neil
1988 360TE AMG
Reply With Quote
Old 08-17-2001, 09:27 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have never had this problem. Sorry.

Maybe you have a problem with the speedo head.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
speedo cable removal at transmission lee polowczuk Tech Help 9 11-24-2004 09:01 AM
Speedo cable question 230/8 SL Forum 0 06-14-2004 10:57 AM
Tech Tip: 124 Parking Brake Cable csnow Tech Help 0 09-08-2003 11:53 AM
86 300E speedo cable rich30769 Tech Help 2 07-01-2001 12:39 AM
W124 Sunroof cable bad? atikovi Tech Help 2 03-16-2001 11:17 AM

All times are GMT -4. The time now is 01:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page