Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-14-2008, 12:02 AM
Registered User
 
Join Date: May 2008
Posts: 1
Question '92 300TE 4matic SLS valve noise ??

Hi everybody,
the leveling valve under the rear of my wagon is making klicking noises. They sound metallic, repeat about every two seconds and are loud enough that you can hear them over the radio when sitting at idle. It could be the valve opening and closing, but I don't think it should be that often or that loud. My pump is working fine, there are no leaks and the fluids are no more than six month old. The back is not sagging either, if anything it sits a little bit to high. Could it be bad accumulators that keep the pump going ?

Any help and advice is greatly appreciated.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page