Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-28-2001, 11:37 PM
zee's Avatar
zee zee is offline
Registered User
Join Date: Aug 2001
Location: Chennai,India
Posts: 28
Question fuel milage

Hi, This is Zee. I am new to this . I have 1990 200TE (yess 200). Being a 2 liter 4 cylinder , I should get ,at the least 8 km/liter (this is how it is calculated in this part of the world). What I am getting now is 4km/liter.

I have changed the injector nozzels, fuel pumps (both), tuning,checked the tire pressure, there is no dragging. I have not changed the fuel pump relay. could that be the problem. any advice would be of great help. Zee
1990 220TE
1988 300GD
1989 yamaha V-MAX(sold)
1993 BMW R100R
1956 Willys Jeep(low bonnet)
1982 Honda XL 250
1987 300D
1994 toyota surf (4runner)2.4 TD EFI
1953 Land Rover

Last edited by zee; 08-28-2001 at 11:47 PM.
Reply With Quote
Old 08-28-2001, 11:50 PM
Ali Al-Chalabi's Avatar
Senior Member
Join Date: Nov 2000
Location: Knoxville, TN
Posts: 1,837
When was the last time the oxygen sensor was replaced?

If it is gone, it could cause the engine to run rich.
Ali Al-Chalabi

2001 CLK55
1999 Dodge Ram 2500 Cummins Diesel
2002 Harley-Davidson Fatboy
Merlin Extralight w/ Campy Record
Reply With Quote
Old 08-28-2001, 11:52 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
Have you also checked the timing, plugs, points, air and fuel filters? Does the engine idle OK, run smoothly? Any strange symptoms, like short on power or hard to start?

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
Old 08-29-2001, 12:05 AM
zee's Avatar
zee zee is offline
Registered User
Join Date: Aug 2001
Location: Chennai,India
Posts: 28
Hi jhon , all that you have mentioned have been checked. no abnormal , except while desselarting the car gallops(sort of!!)

Ali , no the oxygen sensor was never changed. I shall also try that. thankz
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
collapsed gas tank 1987MB260E Tech Help 6 09-09-2004 02:30 PM
does brand of fuel affect milage, just switched brands and milage went up by 3mpg olpos Open Discussion 3 09-06-2004 01:50 PM
Fuel Smell after Fuel Line R/R jriewer Tech Help 3 03-16-2004 11:47 AM
fuel injection problems bad122452 Tech Help 0 08-05-2003 08:25 PM
1982 380SL fuel problem Benzene Tech Help 5 06-12-2001 10:47 AM

All times are GMT -4. The time now is 08:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page