Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-30-2008, 04:32 AM
johnathan1's Avatar
Registered User
 
Join Date: Feb 2008
Location: Downey, SoCal
Posts: 1,171
Thoughts on W140

I recently sold my W126 and W123 in favor of a W140...Let me just say that I miss my W126 already (not the 123 tho, sorry guys! )...I still haven't formulated a specific opinion on what I think about the W140 as a whole, but I feel that the W126 is probably the better car, overall...

It seems like Mercedes had something different in mind when they designed the W140 than the W126, like they were more focused on being the most advanced, rather than quality and longevity (just my opinion, could be wrong).

So far my W140 has been trouble free, aside from the nightmarish Bose stereo (what you've heard is true...LOL) Definitely handles better than the W126, but doesn't feel as smooth or as solid (purely subjective)

Anyway, that's my abbreviated W140 comparison to the W126...

Feel free to interject!
__________________
Current cars:
2001 ML320, 154k miles
1995 E320, 90k miles

Last edited by johnathan1; 07-30-2008 at 04:44 AM.
Reply With Quote
  #2  
Old 07-30-2008, 06:32 AM
bobs's Avatar
Registered User
 
Join Date: May 2007
Location: Richmond, VA
Posts: 310
What's wrong with the Bose stereo? It sounds great on both of my cars.
__________________
"It's not about how fast you can go, but how well you can go fast."

Bob in Richmond

'97 S320 (LWB), Ruby Red Metallic, 73k miles
'97 S420V, Smoke Silver Metallic, 155k miles
Reply With Quote
  #3  
Old 07-30-2008, 12:09 PM
johnathan1's Avatar
Registered User
 
Join Date: Feb 2008
Location: Downey, SoCal
Posts: 1,171
92'-93' have the problematic 7 channel amplifier (old style) that goes bad quite commonly...along with the head unit, tuner box, and cd changer...all of which are bad on my car. Costs a pretty penny to fix, whether you go aftermarket or repair the stock equipment.
__________________
Current cars:
2001 ML320, 154k miles
1995 E320, 90k miles
Reply With Quote
  #4  
Old 07-30-2008, 04:07 PM
johnathan1's Avatar
Registered User
 
Join Date: Feb 2008
Location: Downey, SoCal
Posts: 1,171
Wow, nobody? I'm kinda surprised!
__________________
Current cars:
2001 ML320, 154k miles
1995 E320, 90k miles
Reply With Quote
  #5  
Old 07-31-2008, 09:36 AM
bobs's Avatar
Registered User
 
Join Date: May 2007
Location: Richmond, VA
Posts: 310
Quote:
Originally Posted by johnathan1 View Post
92'-93' have the problematic 7 channel amplifier (old style) that goes bad quite commonly...along with the head unit, tuner box, and cd changer...all of which are bad on my car. Costs a pretty penny to fix, whether you go aftermarket or repair the stock equipment.
Interesting. . . I didn't realize the stereos got changed then. I have the 11-channel units in my W140s and they both are still going strong (crosses fingers ). If you have that much stuff wrong, I'd say its time to go aftermarket unless you're trying to do a restoration project. Re-use the speakers & wiring harness where you can and enjoy the modern technology.
__________________
"It's not about how fast you can go, but how well you can go fast."

Bob in Richmond

'97 S320 (LWB), Ruby Red Metallic, 73k miles
'97 S420V, Smoke Silver Metallic, 155k miles
Reply With Quote
  #6  
Old 07-31-2008, 07:15 PM
syljua's Avatar
C140 CL500
 
Join Date: Jan 2005
Location: Norway
Posts: 132
Quote:
Originally Posted by bobs View Post
Interesting. . . I didn't realize the stereos got changed then. I have the 11-channel units in my W140s and they both are still going strong (crosses fingers ). If you have that much stuff wrong, I'd say its time to go aftermarket unless you're trying to do a restoration project. Re-use the speakers & wiring harness where you can and enjoy the modern technology.
Beware then, that both old and the newer version (which BTW, even with 11 speakers, is still a 7 channel system...), have 2 ohm speakers, not
4 ohm which is more common in the car stereo world.

br,
syljua
__________________
1998 CL500 W140
1984 230E W123
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page