Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2008, 05:05 PM
Registered User
 
Join Date: Jun 2004
Location: Toronto, Canada
Posts: 27
1990 300E crank no start

The car was sitting for 3 weeks and upon start up it cranked but no start. I checked the cap, etc and everything seemed fine. Start to drive and it has a low speed miss that goes away and then on hot restart starts but half hour later won't.

I hear the fuel pump energize. what are the symptoms of crank angle sensor or coil pack? I hate to throw parts at it needlessly. Again cranks well and battery OK.

Cheers

Walter

__________________
Walter Sawczak
1990 300 E
1993 Lincoln Mark VIII
1983 Jaguar XJ6
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page