Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-09-2001, 04:55 PM
Registered User
 
Join Date: Nov 2000
Location: Los Angeles, CA/ Hilo, HI
Posts: 92
Interior illumination on switches etc

The illumination on all my interior switches went out on my 400E just yesterday after I removed the ATA (factory-Alarm) control unit. Could this be related?
The dash illumination works fine, its just the rest of all the switches and controls that are no longer illuminated when I turn on the headlights.
I can't seem to find which fuse is assigned to this function or is there a relay that controls the illumination on all the switches and controls? Any help would be greatly appreciated.
Thanks,
F.J.
__________________
F.J.
81 300 SD grey/palomino 168K miles
84 190E 2.3 black/grey 64K miles (wrecked)
85 190E 2.3 maroon/palomino 92K miles
88 300E desert red/palomino 204k miles
(made to look like a '94-95)
92 400E desert taupe/creme beige 120K miles
(converted to 94-95 E420 looks)
Reply With Quote
  #2  
Old 09-09-2001, 10:20 PM
Senior Member
 
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
There is a fuse on the back of the instrument cluster. It looks like a twist in bulb but it is red in color. There's also an amplifier for the lights located on the right side of the steering column behind the instrument cluster.
Reply With Quote
  #3  
Old 09-10-2001, 03:02 AM
Registered User
 
Join Date: Nov 2000
Location: Los Angeles, CA/ Hilo, HI
Posts: 92
Thanks, I 'll take a look at it next chance I get and will post how things went.
Thanks again,
F.J.
__________________
F.J.
81 300 SD grey/palomino 168K miles
84 190E 2.3 black/grey 64K miles (wrecked)
85 190E 2.3 maroon/palomino 92K miles
88 300E desert red/palomino 204k miles
(made to look like a '94-95)
92 400E desert taupe/creme beige 120K miles
(converted to 94-95 E420 looks)
Reply With Quote
  #4  
Old 11-11-2001, 01:41 PM
Registered User
 
Join Date: Nov 2000
Location: Los Angeles, CA/ Hilo, HI
Posts: 92
Hi Stan,
I finally managed to order the part from MB and get it done. All fixed now. It was exactely as you said. Thanks a lot!
Sincerely,
F.J.
__________________
F.J.
81 300 SD grey/palomino 168K miles
84 190E 2.3 black/grey 64K miles (wrecked)
85 190E 2.3 maroon/palomino 92K miles
88 300E desert red/palomino 204k miles
(made to look like a '94-95)
92 400E desert taupe/creme beige 120K miles
(converted to 94-95 E420 looks)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Window switches slowdriver ML, GL, G-Wagen, R-Class, Unimog, Sprinter 11 09-21-2004 10:18 AM
Window switches clean/repairable? MBwD Diesel Discussion 9 09-04-2004 08:07 PM
82 300TD I want my window switches to light up!!!! nibiru Diesel Discussion 17 10-17-2003 12:10 PM
Window switches in 1989 300E yambrovich Tech Help 1 06-13-2003 11:39 PM
window switches metalman Tech Help 2 06-05-2000 02:50 PM



All times are GMT -4. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page