Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-27-2008, 05:28 PM
C280 Sport's Avatar
Registered User
 
Join Date: Sep 2008
Location: NY&FL
Posts: 159
HELP!! Many C280 Issues here

2000 C280. 73,000 MILES. hard shifting transmisson from 2nd to 3rd. Lack of power. The cabin filter makes a poping sound when the car is started with the ac off or when it starts to get going. The breaks also squeak like a mad man and the sterring makes a sound when it is cold out and when turned to the left.

Any input would be great.

__________________
2015 ML350 4Matic. Wifes DD
2015 GLK350 4Matic. My winter DD
2012 E350 4Matic. Road Trip car
2009 CLK350 Coupe Designo.Kleemann Tune For nice days/DD
2006 CL600. V12.Eurocharged Tune. Enough said
2005 CLK55 AMG Coupe.Kleemann Tune. For the sound and style
2004 CLK320 Cabriolet. 2005+ Interior swap. For the sunny Florida days & beach days
Reply With Quote
  #2  
Old 09-27-2008, 06:25 PM
Registered User
 
Join Date: Sep 2004
Location: Seattle
Posts: 1,934
I don't think those are related. What is the sound the steering makes? Is it a groaning sound? Have you inspected the cabin air filter? There could be a lot of leaves and stuff in there. Are the brakes original? I think people here recommend Textar. Some brands squeal more. You might have Pagid in there or something else. I don't know about the trans. Mine would do that under very specific conditions. So I just don't do that and it doesn't do that...
__________________
1998 C230 330,000 miles (currently dead of second failed EIS, yours will fail too, turning you into the dealer's personal human cash machine)
1988 F150 144,000 miles (leaks all the colors of the rainbow)
Previous stars: 1981 Brava 210,000 miles, 1978 128 150,000 miles, 1977 B200 Van 175,000 miles, 1972 Vega (great, if rusty, car), 1972 Celica, 1986.5 Supra
Reply With Quote
  #3  
Old 09-27-2008, 06:30 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Check your part load adaptation values.

Put some OE pads on it.

Check your P/S fluid level and replace the reservoir if its level is OK.

__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page