Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-13-2008, 11:15 AM
Registered User
 
Join Date: Jan 2006
Location: Northeast,Pa.USA
Posts: 7
1987 190e starting

Hi,
I have a 1987 190e that starts great when cold.I drive it for a few minutes to say Wal-mart and when I come out it will crank over for 30 seconds before it catches.Then it runs well.I bought a new OVP relay and installed it.Same problem and the idle races up and down.If I pull the 1 fuse out the idle flattens out to where it should be.Any help would be appriciated.
Thanks,
Jeff

Reply With Quote
  #2  
Old 10-13-2008, 12:32 PM
Registered User
 
Join Date: May 2006
Posts: 86
Cold start valve?
Reply With Quote
  #3  
Old 10-13-2008, 01:23 PM
Registered User
 
Join Date: Jan 2006
Location: Northeast,Pa.USA
Posts: 7
1987 190e hard start

the car will start in morning whether it is warm or cold outside.(70dgrees down to 36degrees so far)I was under the impression cold start valve only operated under 50 degrees or so.
Reply With Quote
  #4  
Old 10-13-2008, 01:37 PM
slk230red's Avatar
WECO Installer
 
Join Date: Jul 2006
Location: Tampa, FL
Posts: 819
Quote:
Originally Posted by mrbonesjk View Post
Hi,
I have a 1987 190e that starts great when cold.I drive it for a few minutes to say Wal-mart and when I come out it will crank over for 30 seconds before it catches.Then it runs well.I bought a new OVP relay and installed it.Same problem and the idle races up and down.If I pull the 1 fuse out the idle flattens out to where it should be.Any help would be appriciated.
Thanks,
Jeff
If you are having idle issues, it might be your Idle Control Valve. If you pull the fuse out of the OVP relay and the idle goes down, what you are doing is removing the 12v feed to the Idle Control Valve. I would first look at all of the vacuum hoses in the Idle Control Valve circuit and replace if necessary. You might also try cleaning the Idle Control Valve.
Instead of pulling the fuse out of the OVP relay, you might try unplugging the ICV to see if that changes your starting and idle problem.

__________________

1993 190E 2.3
2001 SLK230
1971 LS5 (454) Corvette Convertible
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page