Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-18-2001, 04:07 PM
Posts: n/a
dead instrument panel

I have a 1987 300E. My gas,oil,heat,Rpm gauges all qiut. There is also a clicking sound coming from under the dash. What do I do? Also my head lights (low beam) do not come on. HELP!
Reply With Quote
Old 09-18-2001, 10:00 PM
Posts: n/a
I am not sure of your model, but on my '81 sl I simply plucked the instrument cluster out and plugged in all the connections. One has to first remove the steering wheel. I have no air bag so I simply pried the center pad off from the wheel (it just pops in) and removed the large flange nut. Then simply pull wheel off by hand. Make sure the wheels and steering are straight so you can get it back on in the correct position. To remove the panel one inserts a piece of clothes hangar wire with a 1/2" ninety degree bend on the end down each side. Rotate the wire to put bent leg in toward the panel and pull.

If you have air bag, DO NOT DO THIS without first disarming bag. It can kill you.
Reply With Quote
Old 09-19-2001, 02:46 PM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Try the fuses!!!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 09-19-2001, 04:29 PM
ebennz's Avatar
Join Date: Nov 2000
Location: Hurricane, West Virginia
Posts: 878
check all your FUSES.
most likely that is what it is.

welcome to mercedes shop

*92 400e 124.034, SOLD

*92 300e 124.030, SOLD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just "Renewed" the instrument panel, lights and gauges and odometer Eric Eliel Diesel Discussion 21 01-06-2012 12:17 AM
Instrument panel dead '94 SL500 jcciem Tech Help 11 02-09-2005 10:40 PM
Help! Instrument panel dead, no turn signals Roger65 SL Forum 8 03-05-2004 10:48 AM
Instrument Panel Lights - This Worked jcd Diesel Discussion 1 10-22-2001 11:47 AM
dead instrument panel drjohn Tech Help 3 09-19-2001 02:05 AM

All times are GMT -4. The time now is 06:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page