PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   W124 (94 E420) wiper, high beam, power window, sunroof, defrost, etc problems... (http://www.peachparts.com/shopforum/tech-help/237161-w124-94-e420-wiper-high-beam-power-window-sunroof-defrost-etc-problems.html)

BennyNg 11-06-2008 12:50 AM

W124 (94 E420) wiper, high beam, power window, sunroof, defrost, etc problems...
 
Car is a 94 E420.



With everything working, when you use the wiper or the high beam flashers, then many other electrical components stop working. The items that stop working: (all electrical windows, sun roof, rear defrost and sometimes the electric seat adjustment.)


Tried to pull out and clean the combo relay (201 821 02 47 -Multi-function relay used for blinker : hazard warning : heated rear window : wiper)


When re-inserted, everything works. Until you use the wipers or the high beams. Then the various other electrical items stop working.



Also,if I get underneath the multifunction relay and try to push the wires up toward the relay, all the other electrical function will work again until I try to use the high beam flasher and the wiper.


Replaced the combo relay (201 821 02 47) and the symptoms are still there.


The new relay is one that superceeds the relay that was in the car. There is an extra connecting pin. It seems to fit, but I wonder if that is part of the issue.

Will pull out all related fuses tonight, and clean all contacts and fuses based on some reading here earlier. Will also, re-attempt to reset the relay better.


Thanks In Advance!


Benny


Ashman 11-06-2008 02:16 AM

maybe the turn signal stalk combination switch? I would think since wipers/highbeam activation is on the turn signal stalk, that it could be a place to look

BennyNg 11-06-2008 08:35 AM

hmmm, how hard is it to take that out, and inspect, clean, and possibly replace?

lafooy 11-06-2008 10:26 PM

1 Attachment(s)
Users replied to me when my headlights would not turn on for my 1994 e320. User nissanzx1 mentioned, "Order the combo switch online. Once it's delivered, remove the lower dash on the drivers side and unplug the existing combo switch. Plug the new one in and test the functions. If it doesn't fix it, return it to the online vendor and start from square one again. If it fixes it, remove the steering wheel and replace the switch."
Here is the link to the post.
http://www.peachparts.com/shopforum/tech-help/233568-w124-94-e320-issue-headlights.html#post1978227

I was able to reach my combo switch connector by removing the black plastic cover above the pedals (can see it hanging in picture on the post i mentioned). You can say it is above the hood release I guess.

I have attached pics in the above link and one more in this post of my combo switch which should be similar to your car's. Not sure if you would like to check the connector before you purchase anything though. I bought mine through allpartsexpress through the links at the top of this page


All times are GMT -4. The time now is 08:40 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website