Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-23-2001, 10:16 PM
Posts: n/a
Fuel pump?

I have a 91 300SEL with 113000 miles. Recently (1 month or so) I have noticed that the car makes a loud humming noise while running. The noise starts when I crank the engine over and is present on the last position of the ignition switch before the engine cranks. I tracked the noise and the noise seems to be coming from the passenger rear area. Fuel pump gone???

Should I replace ASAP or can I wait?
Other diagnostic checks?

Instructions on how to change the fuel pump if this is the culprit would greatly be appreciated!!!

91 300SEL 113000mi
Reply With Quote
Old 09-23-2001, 11:39 PM
Registered User
Join Date: Sep 2001
Location: Queens, NYC
Posts: 158
It sounds like A fuel pump to me, I believe there is more than one.

The fuel pump cycles for about 1-2seconds before starting the car when the key is in the last position before cranking. I've had them go in 2 of my cars, but I never had the luxury of any advanced notice.
2003 S500 Black/Charcoal
1990 560SEL 61k Arctic White/Grey

1988 420SEL Black/Palomino Sold @ 85k
1987 420SEL Midnight Blue/Grey
1986 420SEL Diamond Blue/Grey
1983 380SEL Champagne/Palomino
Reply With Quote
Old 09-24-2001, 01:59 AM
zee's Avatar
zee zee is offline
Registered User
Join Date: Aug 2001
Location: Chennai,India
Posts: 28
It is indeed ,the fuel pump.I believe yours have two of them, one in front and the other at the back. It is a simple remove and refit job with basic tools. good luck
1990 220TE
1988 300GD
1989 yamaha V-MAX(sold)
1993 BMW R100R
1956 Willys Jeep(low bonnet)
1982 Honda XL 250
1987 300D
1994 toyota surf (4runner)2.4 TD EFI
1953 Land Rover
Reply With Quote
Old 09-24-2001, 09:59 AM
Registered User
Join Date: Jan 2000
Location: PA
Posts: 5,440
NO, the fuel pump is not gone, its there making the noise you hear. LOL

You might be able to replace the bearings in the pump and save a lot of bucks. If it doesn't hum and the car quits running, try tapping the pump with the hammer in the MB tool kit. That trick got me home from OH onetime in my 300SEL6.3. I guess that's why MB put the hammer in the tool kit, because I never used it for anything else.

If you are going to repair the pump, the quicker you do it the better because the pump is destroying itself and if you let it go too long, it may not be repairable.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
380SL Fuel Pump Replacement Causes Rough Idle & Other Problems? ezrider SL Forum 8 03-14-2004 12:12 PM
190E Fuel Pump Relay/Electrial problem treynolds Tech Help 0 05-29-2003 10:59 AM
Need help with fuel pump relay wireing xp190 Tech Help 0 12-30-2002 04:27 PM
300D fuel pump JHZR2 Diesel Discussion 3 02-04-2002 09:34 PM
C280 Fuel Pump David C Klasse Tech Help 0 10-06-2001 05:36 AM

All times are GMT -4. The time now is 06:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page