Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2008, 09:44 AM
Registered User
 
Join Date: Jan 2006
Location: Herndon, VA
Posts: 27
C230 #4 misfire

Car: 97 C230, 145K miles

Problem: a couple of weeks ago my C230 suddenly experienced a CEL, ran rough.. no power..

I borrowed a OBD-II meter > the CEL code read that #4 was misfireing. I subsequently replaced all spark plugs [they had better than 80K on them] and seemingly all was fine .

A few days later > car experienced another CEL, code read #4 misfire . I replaced the spark plug boot and thought all was fine

Car ran great for a few more days .. then yesterday > same thing.. car > when cold runs great for about 30 min.. then it MIGHT suddenly misfire > #4 misfire and it chugs along on 3 cylinders.

Why does it do that?? I've replaced the spark plug and the spark plug cap..

Is it the coil?

recommendation for fix??

__________________
Kim Langley
97 C-230
80 911 SC
73 2002Tii
Reply With Quote
  #2  
Old 12-05-2008, 10:46 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Swap that coil with the other and see if the code follows the suspect coil..
__________________
A Dalton
Reply With Quote
  #3  
Old 12-05-2008, 02:33 PM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,108
I too would bet on it being the coil.....if you've made sure all other items are good, it'd have to be.

__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 83k - mine - (OC-85,500)
'17 Metris(VITO!) - 13k - wifes (OC-17k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'01 E320 - 179k - dad's (OC-182,500)
'07 E350 Wagon - 131k - dad's (OC-132,500)
'01 SL500 - 51k - dad's (OC-52,000)
'16 E400 4matic Sedan - 57k - Brothers (OC-64,000)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page