PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Misfire at high revs after replacing pcv to inlet breather hose on 97 E420 (http://www.peachparts.com/shopforum/tech-help/239707-misfire-high-revs-after-replacing-pcv-inlet-breather-hose-97-e420.html)

alabbasi 12-07-2008 07:53 PM

Misfire at high revs after replacing pcv to inlet breather hose on 97 E420
 
Wondering if people can help here. The breather hose was in complete tatters on my 1997 E420. This is the funny shaped hose that runs from the rear right side of the engine to just under the inlet pipe on the M119 engine.

I had to remove, then reinstall a sensor that sits on the side of the inlet in order to fit it.

The car seemed to run well after i put everything back together but at high revs, the engine has a misfire. The it does catch itself and go back to normal at the lower rev range.

This seems to only happen at 4000rpm + and it will not rev much higher/

Any thoughts as to what the problem is?

Arthur Dalton 12-07-2008 10:04 PM

You are testing the RPMs in N or P ...the car has a rev limit of 4K in those selections for No Load torque converter protection.
Take the car down the road and try it. [ use a lower gear so you don't have to speed]

..or , it can betested by going over 12 MPH and shift into N and gas it ..it should then go passed the 4K with no problem... shift back to gear after the rpms settle back down..this is only a test...

alabbasi 12-07-2008 10:40 PM

Thanks for the response. The car also seems to miss up the rev range when I boot it in gear. Strangely enough, it seems more responsive off the mark then before but when I floor it down the road. I get the miss.

Arthur Dalton 12-07-2008 10:42 PM

Did you test the 4k limit I mentioned??

alabbasi 12-07-2008 11:17 PM

Quote:

Originally Posted by Arthur Dalton (Post 2042163)
Did you test the 4k limit I mentioned??

No, I just floored it before and noticed that it would run badly. When It returned to normal. I tried to recreate the problem in neutral and did so, so i thought it would be easier to explain it.

This is not like a rev limiter issue where the rev counter would bounce off the 4k range. To add to that, there is a definite miss in the system that is causing the the whole car to rock from side to side.

The only wire touched was the one with the sensor that goes into the intake tube. I had to get that out of the way to get anything done.

Many thanks!


All times are GMT -4. The time now is 06:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website