Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-09-2008, 04:53 PM
Registered User
 
Join Date: Dec 2007
Location: Fallbrook, CA
Posts: 393
W124 seatback problem

Hey guys,

I have a '92 300 CE and have a seatback problem. It does not seem to "lock". It seems to move forward on both seats even when the car is turned off. Is this normal? Shouldn't they lock into position as a matter of safety?

Does anybody have any info on this? Is it the seat switch?

__________________
Norm K.
'97 E420 Sport
'06 E350 Sedan
'67 Mustang Coupe
'70 F-250
'15 VW Jetta
Reply With Quote
  #2  
Old 12-09-2008, 05:45 PM
mbzman's Avatar
Registered User
 
Join Date: Nov 2008
Location: Canada
Posts: 600
My '89 300CE does the same thing. The owners manual says the only time the seats are locked is when both doors are closed and the engine is running. If those conditions are not met then the seat backs will not lock into position. On my '89 CE the seat backs do not lock either, even with the requirements to lock being met. If I recall correctly, the seat back locks are vacuum operated.
Reply With Quote
  #3  
Old 12-09-2008, 07:31 PM
Registered User
 
Join Date: Jul 2008
Posts: 121
i had the same problem , pulled the lever and layed my seat all the way down and i was able to put the catch back in it
Reply With Quote
  #4  
Old 12-09-2008, 08:22 PM
Registered User
 
Join Date: Dec 2007
Location: Fallbrook, CA
Posts: 393
Quote:
Originally Posted by mbzman View Post
My '89 300CE does the same thing. The owners manual says the only time the seats are locked is when both doors are closed and the engine is running. If those conditions are not met then the seat backs will not lock into position. On my '89 CE the seat backs do not lock either, even with the requirements to lock being met. If I recall correctly, the seat back locks are vacuum operated.

That was the problem! I should have read the OM. Thanks! I almost had my mech tear into the problem. I'm new at this coupe thing....

__________________
Norm K.
'97 E420 Sport
'06 E350 Sedan
'67 Mustang Coupe
'70 F-250
'15 VW Jetta
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page