Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-20-2008, 11:09 AM
Registered User
 
Join Date: Dec 2003
Posts: 154
2000 C280 722.6 trans problem

Greetings all,

I'm stumped on this one...2000 C280, 94k miles. trans will not pull in any gears..acts like its in neutral..no history on the car. Customer declined any inspection/repair/ just traded it off...

Clean car, no obvious signs of abuse..verified that the shifter is mechanically connected to the trans..fluid level appears to be good. Any pointers?

Reply With Quote
  #2  
Old 12-20-2008, 12:19 PM
Registered User
 
Join Date: Aug 2001
Location: Milford, DE
Posts: 1,458
Does the display in the instrument cluster that indicates what gear you are in show that the transmission is in gear when you shift it out of park?

I was under the impression that the 722.6 didn't have a mechanical link between the shifter and the transmission - I think gear selection is electronic.
__________________
98 Dodge-Cummins pickup (123k)
99 CLK320 (352K)
08 SL550 (113K)
13 GLK250 (86K)
14 E250 (61k)
Reply With Quote
  #3  
Old 12-20-2008, 12:54 PM
Registered User
 
Join Date: Dec 2003
Posts: 154
just dropped the pan.. no fluid.. and no filter...gonna fill it up..what fluid would you buy at napa? no buying the MB branded stuff..what is the spec?
Reply With Quote
  #4  
Old 12-20-2008, 01:12 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
MB fliud for the 722.6 or .9 trans ONLY.

NO other fluid has the propriatary additive pack MB uses. Is Dex III, but unique.

You ought to have a CEL lit up; you wont be able to read or reset it w/o use of a high end scanner.

Is also touchy about fill levels. Do you have the factory dip stick tool?
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
  #5  
Old 12-20-2008, 07:22 PM
Registered User
 
Join Date: Jan 2007
Posts: 154
Quote:
Originally Posted by TMAllison View Post
MB fliud for the 722.6 or .9 trans ONLY.

NO other fluid has the propriatary additive pack MB uses. Is Dex III, but unique.

You ought to have a CEL lit up; you wont be able to read or reset it w/o use of a high end scanner.

Is also touchy about fill levels. Do you have the factory dip stick tool?
Been using Pennzoil Multi ATF in a 99 C280 with zero problems for over 20k miles.
__________________
1999 C280
Reply With Quote
  #6  
Old 12-21-2008, 01:23 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Quote:
Originally Posted by 300B View Post
Been using Pennzoil Multi ATF in a 99 C280 with zero problems for over 20k miles.
Check back when you've put 253k on it like my 722.6 has and we'll talk.

$35 incorrect fluid vs <$100 correct fluid vs >$3500 trans.....

The OP prob doesnt have a TC drain plug so would use somewhere around 4L rather than +/-8, so would be even cheaper.

That said, finding no fluid or filter in the trans makes one suspect it will not end well...... If it gets rebuilt ro replaced you'll need a new TC too and will need some way to assure the cooler is also free of debris.
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k

Last edited by TMAllison; 12-21-2008 at 01:35 PM.
Reply With Quote
  #7  
Old 12-23-2008, 08:52 PM
Registered User
 
Join Date: Jan 2007
Posts: 154
Well Gilly posted about a 722.6 with over 350k I believe with the factory fill for what it's worth.
__________________
1999 C280
Reply With Quote
  #8  
Old 12-24-2008, 02:01 AM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
Quote:
Originally Posted by 300B View Post
Well Gilly posted about a 722.6 with over 350k I believe with the factory fill for what it's worth.
I think it was in the 4's. Mine went 220ish on its fatcory fill to the best of my knowledge.

Whats that got to do with RE-filling with the wrong fluid?
__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
  #9  
Old 12-24-2008, 03:05 PM
Registered User
 
Join Date: Jan 2007
Posts: 154
Quote:
Originally Posted by TMAllison View Post
I think it was in the 4's. Mine went 220ish on its fatcory fill to the best of my knowledge.

Whats that got to do with RE-filling with the wrong fluid?
Well the fluid would be pretty well darn shot by then yet it still kept going.

Makes me think the 722.6 won't die if one uses a good quality multi ATF.

That's gotta be better than a 200k plus factory fill.
__________________
1999 C280
Reply With Quote
  #10  
Old 12-30-2008, 03:40 PM
Registered User
 
Join Date: Dec 2003
Posts: 154
the rest of the story is as follows..

bought the car, tech in the shop wanted to buy car badly. Tech had removed the conductor plate and fluid. Bought a conductor plate... filled the trans, car shifted well, then ...drove 100 miles out of town...pulled off I40, when i did...trans fluid leaked out of the front somewhere (near the exhaust crossover?) , then the trans would not pull at all in any gear...

Towed it back home...trans acted fine...with a slight flare in the 2-3 shift.

drove on the expressway ...did it again..

trans is slightly over filled per the mb dipstick.. could this be the culprit?
Reply With Quote
  #11  
Old 12-30-2008, 08:24 PM
Registered User
 
Join Date: Feb 2004
Location: Walnut Creek, CA & 1,150 miles S of Key West
Posts: 4,874
They are touchy on fill level. Check hot and adjust to the upper end of the factory dip stick.

Look at the trans where the harness plugs in for your leak. Oring seals were redesigned a couple of tiems. Should have been finished with revisions by the time your was made. If appears to be the source, check the inside of the harness for fluid; if present follow wires to the computer box and check that end too.

__________________
Terry Allison
N. Calif. & S. of Key West

09' E320 Bluetec 77k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page