Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2009, 09:57 PM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
w126 ccu

Does anyone know if the CCU from an 88 W126 is compatible with the CCU in my '86
420sel? I have had some trouble with mine lately. In the morning it clicks a little when it is really cold outside. Some times when it is clicking, the heater will turn on full blast in short spurts of 2 seconds or so for a little bit and I can see the light turn on and off on the recirculation button. I believe once it was warmed up a bit, I can get it to work properly. When on heat, it does blow at the side vents like it should, but I can't remember if its supposed to blow warm air at the windshield also when its on max heat and on economy mode and not defrost. Mine does blow warm air at the windshield. I purchased an 88 w126 ccu at the junkyards as a spare in case this one goes out soon. I just dont want to pull out my ccu without having a proper replacement. Thanks for reading.

__________________
1984 300SD Orient Red/ Palomino
1989 560SEC
2016 Mazda 6 6 speed manual
1995 Ford F-150 reg cab 4.9 5speed manual
Reply With Quote
  #2  
Old 01-14-2009, 11:27 PM
crashone's Avatar
1983 300SD, 4 speeed
 
Join Date: Jul 2006
Location: Raleighish, NC
Posts: 664
I believe you would be correct since they are both 2nd generation w126. If the old one is fried pull it out and compare to make sure. Otherwise plug and play.
__________________
If it ain't broke take it apart and find out why.

1983 300SD, 4 speed
1994 C280
1987 300TD wagon
1996 HD Road King

Ride in Peace Eric Peterson, Harley of Macon
Reply With Quote
  #3  
Old 01-15-2009, 05:54 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Sounds like typical cracked solder joints inside the CCU.

If you are good with small things, you should be able to get it apart and see for yourself. If so, touching up the solder joints should revive the unit. Alternatively, you may have a button that is intermittently closing even when its in the up position. I'll bet on the solder joints, though...


-tp
Reply With Quote
  #4  
Old 03-29-2009, 11:04 PM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
ok, this weekend I had a field day at pick n pull as I found a red interior 420sel. Since the ccu I put in a few months ago will not turn off, I got one from the 87 in the junkyard. I installed it but it is always on too, but this one will not go into economy mode at all. A/C in always on. This is the third ccu that has done this. Could a bad klima do this to the car? I unforunatly didnt pull the klima out of that car because it didnt click that that could be the possibility. This car only had 117k on it and it looked like it actually had those miles too. I couldnt really see any cracks in the solder in the other ccu's either so I cant be sure if they are good or not. If anyone has ever had this problem I would appreciate any input. Thanks.
__________________
1984 300SD Orient Red/ Palomino
1989 560SEC
2016 Mazda 6 6 speed manual
1995 Ford F-150 reg cab 4.9 5speed manual
Reply With Quote
  #5  
Old 03-30-2009, 05:03 PM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
BUMP Anyone?
__________________
1984 300SD Orient Red/ Palomino
1989 560SEC
2016 Mazda 6 6 speed manual
1995 Ford F-150 reg cab 4.9 5speed manual
Reply With Quote
  #6  
Old 03-30-2009, 11:52 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Man, I'll have to dig into the schematics.

Are there any relays associated with compressor operation, etc? I guess we're looking for something outside the CCU itself at this point......
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #7  
Old 03-31-2009, 12:14 AM
E150GT's Avatar
I'm a chicken
 
Join Date: Sep 2006
Location: SAN ANTONIO, TEXAS
Posts: 1,148
Quote:
Originally Posted by tinypanzer View Post
M I guess we're looking for something outside the CCU itself at this point......
im only assuming this because i have tried three units and they are almost all the same problem.
__________________
1984 300SD Orient Red/ Palomino
1989 560SEC
2016 Mazda 6 6 speed manual
1995 Ford F-150 reg cab 4.9 5speed manual
Reply With Quote
  #8  
Old 03-31-2009, 02:08 PM
Cal Learner's Avatar
Registered User
 
Join Date: Aug 2006
Location: Marysville, CA
Posts: 781
Quote:
Originally Posted by tinypanzer View Post
Man, I'll have to dig into the schematics.

Are there any relays associated with compressor operation, etc?...
Yes, the Klima (compressor cut-off) relay the OP mentioned.
__________________
1988 California version 260E (W124)
Anthracite Grey/Palomino
Owned since new and still going strong and smooth
MBCA member

Past Mercedes-Benz:
1986 190E Baby Benz
1967 230 Inherited from mom when she downsized
1959 220S Introduced me to the joys of keepin' 'em goin'

There are only 10 kinds of people in the world--those who understand binary and those who don't
Reply With Quote
  #9  
Old 03-31-2009, 09:34 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Check for a short in the in-car temp sensor.
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #10  
Old 04-01-2009, 12:32 AM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
I am trying to print out the 45 page troubleshooting guide to .pdf for you, but my machine keeps crashing.

It did suggest testing the interior air temp sensor....... Among other things. I will post more tomorrow and if I can get the pdf to work I will email it to you.

__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page