Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2009, 05:12 PM
Registered User
 
Join Date: Jul 2007
Location: Raleigh, North Carolina USA
Posts: 61
Help - my horn/alarm goes off when I put on my headlights- '90 300 SEL

Please help - I am moving and need to drive the car tonight, but the alarm or horn, hard to tell which, goes off when I put on the headlights on my 1990 300 SEL.

I disconnected the alarm (underneathe the passenger side 4 years ago so I doubt it's that). But do not know.

I had a mechanic replace a rotor about a week ago and the ABS stayed on after that and also the outside temperature light does not go on as well anymore. Been busy so I haven't taken it back yet.

I took out the fuses for the "warning system" and "horn", but when I turn the headlights on, a super loud sound comes out under the hood.

Heard of this? How can I disconnect? Please help, I need to drive the car tonight.

Matt
1990 300 SEL
__________________
1990 Mercedes 300 SEL (320,000 miles)
1994 Mercedes E420 (140,000 miles)
Reply With Quote
  #2  
Old 01-15-2009, 11:44 PM
Registered User
 
Join Date: Mar 2001
Location: Schenectady, new york
Posts: 229
You need to disable the alarm horn. It's located in the windshield wiper motor area. Remove the weatherstripping, remove the retaining clips. Lift up the passenger side and the horn like apparatus is the thing you need to disable. You should be able to just reach in with it lifted up and unscrew(phillips head as i recall) the power going to it. You have the option of removing the wipers and lifting the whole thing off for greater access. I recall just lifting up the passenger edge and doing it. Fixing the fault, I have no idea. Mine will occasionally still flash the headlights after locking it. But the alarm does not sound, and the lights flashing ends after a minute I think.


'94 SL 500 40,000
'91 300SD 534,000
'87 300SDSL 236,000
__________________
jcciem
'94 SL5000 60,000
'91 350SDL 545,000
'91 350SD 197,000
'00 E55 AMG 77,000
Reply With Quote
  #3  
Old 01-16-2009, 12:45 PM
Registered User
 
Join Date: Jul 2007
Location: Raleigh, North Carolina USA
Posts: 61
Thank you very much - I appreciate it.


By the way, what do you think is causing this? If I was to fix it - what would I do?

In the meantime, disconnecting the alarm hound sounds like the way to go.
__________________
1990 Mercedes 300 SEL (320,000 miles)
1994 Mercedes E420 (140,000 miles)
Reply With Quote
  #4  
Old 01-16-2009, 03:12 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,171
That's very bizarre. Disconnecting the alarm module under the passenger footwell should completely disable the alarm. There are two wire groups that go to the alarm, and they should both be disconnected.

The relays that flash the lights and honk the horn are inside that unit, so there is no way you can get the alarm to go off with it disconnected unless you have some after market alarm system installed.



-tp
Reply With Quote
  #5  
Old 01-16-2009, 03:17 PM
Registered User
 
Join Date: Jul 2007
Location: Raleigh, North Carolina USA
Posts: 61
Very true, it is bizarre. I disconnected the alarm around 4 years ago. When the alarm goes off, I hear a clicking noise, but it goes away in a few minutes.


But when I turn on the headlights, I hear a very loud noise, and it is not as loud as the horn (steering wheel).


Could replacing a rotor for the brakes have anything to do with this? I had one put on a month ago and the "ABS" light is still on and never took it back to get it fixed.

Thanks!
__________________
1990 Mercedes 300 SEL (320,000 miles)
1994 Mercedes E420 (140,000 miles)
Reply With Quote
  #6  
Old 04-10-2009, 11:37 PM
Registered User
 
Join Date: Jul 2007
Location: Raleigh, North Carolina USA
Posts: 61
Does anyone have a picture of what the alarm horn looks like?

could disabling somehow screw up the headlamps?
__________________
1990 Mercedes 300 SEL (320,000 miles)
1994 Mercedes E420 (140,000 miles)
Reply With Quote
Old 04-10-2009, 11:37 PM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page