Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-10-2001, 06:25 PM
Posts: n/a
Unhappy benz 190 wont start or do anything help please

Hello everyone I have a problem with my 1985 190e 2.3
the car has been running fine for a year.
suddenly when i let my sister use it things changed.
she went to start it and it's dead
all the other electrical things are working
but when i try to turn it over it does nothing.
i turned on the headlights and tried to start it and there was no power decrease in the lights. it seems to be no power going to the starter or possibly the ignition coil.the starter has worked fine with no signs of trouble
one other thing do the 190e 85 have a diagnostic system?
thanks everyone.
Reply With Quote
Old 10-10-2001, 09:09 PM
Dorsey Lay
Posts: n/a
190 won't start or do anything

Hi, I have the same year and model you have and I recently had the same problem. Iwas driving one day, everything was fine. Turned the car off and tried to re-start nothing. Problem turned out to be battery failure. They can go suddenly, mine was nine years old. Hope this helps!
Reply With Quote
Old 10-11-2001, 03:05 AM
Posts: n/a
Unhappy 190 wont start

thanks but i think the battery is fine because everythig else electrical works. i can hear the fuel pump hissing when i turn the key to the on position.
also headlights are very bright.
seems like the power is not reaching the starter.
i need to know what components could prevent power to getting to the starter such as a relay or something or possibly the ignition or ignition coil.
thanks for any info

Reply With Quote
Old 10-11-2001, 05:19 AM
Neil Eglintine
Posts: n/a

Have you checked the inhibit switch on the transmission? Try starting in neutral instead of park. I think there are two switches so if the park switch has failed, the neutral one should allow you to start the engine.
Reply With Quote
Old 10-11-2001, 05:42 AM
Benzo 300
Posts: n/a
I second the inhibit switch
Reply With Quote
Old 10-11-2001, 05:46 AM
Mike Murrell's Avatar
Registered User
Join Date: Feb 2000
Posts: 2,141
Shot in the dark.

Does the car have an anti-theft device? If so, there may be a toggle switch under the dash that has been "accidentally" switched the other way. It happens.
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC

James Madison - Oppressors can tyrannize only when they achieve a standing army, an enslaved press, and a disarmed populace.

Liberty Firearms Training - After years of trying to regulate California criminals with a never ending stream of gun control laws they have still not given up with the belief that if they make something a crime that criminals will miraculously start obeying the law.
Reply With Quote
Old 10-11-2001, 07:40 AM
mplafleur's Avatar
User Friendly
Join Date: Sep 2001
Location: Lathrup Village, Michigan
Posts: 2,939
My 190E anti-theft will only flash the headlights and honk the horn. I'm not aware that it can inhibit start. I'm sure that if it did, it would disable the fuel pump.

I used to bang on the starter with a wrench on my old '72 dodge to get it to spin.

Starter relay?
Michael LaFleur

'05 E320 CDI - 86,000 miles
'86 300SDL - 360,000 miles
'85 300SD - 150,000 miles (sold)
'89 190D - 120,000 miles (sold)
'85 300SD - 317,000 miles (sold)
'98 ML320 - 270,000 miles (sold)
'75 300D - 170,000 miles (sold)
'83 Harley Davidson FLTC (Broken again) :-(
'61 Plymouth Valiant - 60k mikes
2004 Papillon (Oliver)
2005 Tzitzu (Griffon)
2009 Welsh Corgi (Buba)

Reply With Quote
Old 10-11-2001, 09:09 AM
Registered User
Join Date: Apr 2000
Posts: 166
Had a similar experience with my car. Turned out to be starter solenoid. You need to determine if the small terminal on the solenoid it getting voltage when the ignition switch is turned to the "Start" position. If not, then look at circuits from the ignition switch through to the solenoid. If voltage is there, it is either the solenoid or the starter itself. I understand that the solenoid grounds through the starter, so both units would have to be checked.

Hope this helps. Good luck.
1979 240D
165,000 miles
Reply With Quote
Old 10-11-2001, 12:28 PM
Posts: n/a
Talking 190 wont start

thanks everyone i will check everything you all have posted.l
I will keep you all updated on my progress.
again thanks a lot.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
benz 190 boiseyoungun Tech Help 1 12-21-2004 10:48 PM
190 300sl---engine start problem--1990 fjones Tech Help 0 03-09-2004 06:08 PM
doesn't start, waterblaster the problem ? MB300ENZ Tech Help 9 09-17-2003 10:26 PM
190 e 2.3 1987 benz mr benz Tech Help 4 07-20-2003 04:22 PM
please help me diagnose a no start issue. 300SD(long) RG5384 Diesel Discussion 8 06-14-2003 11:55 AM

All times are GMT -4. The time now is 07:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page