Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-12-2001, 01:43 AM
Squid's Avatar
Registered User
Join Date: Jun 2001
Posts: 69
Unhappy No A/C blower function... what do I do?

I have a 300CE, and last week, the a/c motor died. I know this because I checked the a/c and it was really cold, and when I changed to high temp climate settings, nothing comes out. Anyway, I checked the fuse strip, and found a problem! The fuse was not blown, but one of the terminals that holds an end of the strip was. It looked like it arc'ed to ground, and so I thought replacing it (and the fuse) would do the trick. Unfortunately, it did not. I still have to check and see if current is flowing, but in the meantime, what else can I do? Is the motor shot, and if it is, how do I get to it? Is there another fuse to check? I'd appreciate any help...
89 300CE
91 Supercharged Miata
99 E320 Wagon
Reply With Quote
Old 10-12-2001, 08:15 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
IS there power to the fuse?? If not the electrical portion of the ignition switch is bad. There is a good chance that the whole problem is because the blower motor was drawing too much current(AMPS).
Blower motor is under the hood below the w/s wiper mech. The air intake BOX must be remover to get to the blower, about a 3 hour job.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 10-12-2001, 10:34 PM
Squid's Avatar
Registered User
Join Date: Jun 2001
Posts: 69
Thanks, doc. I know about the ignition switch, I did some "searches" before I posted. I haven't checked the fuse for current, since I don't have a dvm. Will do that tomorrow... what is the typical amperage for the motor, anyway?
89 300CE
91 Supercharged Miata
99 E320 Wagon
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 C43 - A/C Blower Question - Issue 99C43 Tech Help 3 10-06-2004 01:06 PM
124 heater blower / a/c problem....... Eclipse Tech Help 2 10-26-2003 09:57 PM
intermittant W124/300TE blower & A/C Efficiency? ke6dcj Tech Help 2 07-02-2001 12:45 PM
a/c blower problem Stephen Tech Help 1 05-26-1999 09:30 PM

All times are GMT -4. The time now is 02:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page