Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2009, 01:38 PM
glenmore's Avatar
Registered User
 
Join Date: Sep 2002
Location: Los Angeles
Posts: 963
W124 Blower

1991 300CE 154.7m (coming up on my first badge!)

My blower suddenly stopped working from one day to the next. I have read a lot from the archives and have a few questions.

1) I checked the fuse and it looks good. Just to confirm, this is the big one, not in the regular fuse box area but in the box directly behind that also contains a bunch of relays?

2) Next I will check the push button control panel.

3) Most likely problem is then either a) motor, b) brushes in motor, or c) regulator

After reading the tutorials, it was mentioned that some of the motors are sealed with rivets and replacing the brushes on these units takes a lot more effort. Anyone have experience replacing the brushes or should I just have a new motor ready ?

Thanks,

glenmore
1991 300CE
2000 C280
Reply With Quote
  #2  
Old 04-29-2009, 02:03 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,801
Fusable LINK for that blower should be over by the left strut tower.
__________________
A Dalton
Reply With Quote
  #3  
Old 04-29-2009, 07:43 PM
cdplayer's Avatar
Just my Jeep and my S500
 
Join Date: Aug 2006
Location: Sacramento, Calif.
Posts: 581
Blower issues

Email sent
__________________


Selling used Mercedes parts on Ebay...always changing...
cdplayer51 take a look!
____________
Reply With Quote
  #4  
Old 04-30-2009, 01:17 PM
glenmore's Avatar
Registered User
 
Join Date: Sep 2002
Location: Los Angeles
Posts: 963
Quote:
Originally Posted by Arthur Dalton View Post
Fusable LINK for that blower should be over by the left strut tower.
Thank you Arthur! That was it, just a broken fuse. I was looking at the wrong one. No need to dig into the blower.

Thanks again,

glenmore
1991 300CE
2000 C280
Reply With Quote
  #5  
Old 04-30-2009, 01:23 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,801
Very Good...................
__________________
A Dalton
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page