Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-24-2001, 09:20 PM
benzat
Guest
 
Posts: n/a
Question ac not working

1982 380 SEC
the ac is not turning on (tested all buttons) no air at all. on the old ac system

could this car be looking for the cheap fix of a relay?
how do you test the relay on the ac unit?

thanks for any good help
benzat
1982 380 SEC
Reply With Quote
  #2  
Old 10-25-2001, 08:23 PM
goldenbear's Avatar
Registered User
 
Join Date: Mar 2001
Location: NorCal
Posts: 442
benzat,

Perhaps others can provide a more technically accurate response, but I solved a similar problem I was experiencing with my now sold '85 190E by unplugging a line that went to a switch that rested above and to the right of the water pump. (Aux temp switch??) Are you sure you have freon?
__________________
Chris

'04 ML500 - 53k, Inspiration Edition, Desert Silver
'11 Audi A4 Avant - Brilliant Black
'87 300SDL sold
'99 C280 Sport sold
'85 190E 2.3 sold
Reply With Quote
  #3  
Old 10-25-2001, 09:34 PM
benzat
Guest
 
Posts: n/a
no loss of freon...and the heater doesnt work also. no attemt for the motor turning on or the temp control.

benzat
1982 380 SEC
Reply With Quote
  #4  
Old 10-25-2001, 09:41 PM
MIKE FREEMAN
Guest
 
Posts: n/a
FIRST CHECK FUSE #11, IT SHOULD BE IN GOOD COND. AND HAVE NO BURNED CONTACTS ON FUSE HOLDER. IF FUSE IS OK REMOVE THE UPPER KICK PANEL ON PASS. FRONT FOOTWELL.
ON THE BLOWER HOUSING THERE IS A TWO PIN CONNECTOR WITH A BROWN WIRE AND AGREEN WIRE WITH RED TRACER.
WITH THE ENGINE RUNNING AND A/C SWITCHED TO DEFROST TEST FOR BATTERY VOLTAGE ACROSS THESE TWO PINS.
IF YOU HAVE BATT. VOLTS MOTOR IS DEAD!
THE MOTOR CAN BE PURCHASED W/O FAN FOR LESS THAN HALF OF REG. PRICE AND IS EASY TO REPLACE.
MF
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W123 Turn Signal stopped working dave1shere Diesel Discussion 12 07-30-2013 09:42 PM
560sl odometer and speedometer not working robaincltnc Tech Help 6 04-18-2008 09:47 AM
72 220D Odometer not working Mario Slipac Diesel Discussion 7 08-15-2002 10:21 PM
Blower Not Working Don Hicks Tech Help 3 08-14-2002 01:48 PM
Rear defroster not working larrysiny Tech Help 0 11-16-2001 09:21 AM



All times are GMT -4. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page