Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-28-2001, 07:17 PM
Posts: n/a
All Stop Lamps Permanently Illuminated - E500 !!

Just noticed today that stop lamps including high mounted unit illuminate upon ignition and remain illuminated (with ignition on only). Depressing the brake pedal hence communicates nothing to drivers behind me!
Also, antenna rises upon ignition, irrespective of whether radio is on or off. It should only rise if you power on the radio.
I believe this strange event occurred as I was using a car vacuum cleaner. The cleaner plugs into cig lighter and is designed to be run with engine off. Only ignition turned to first indent. Shortly after finishing vacuuming, I turned on engine and it started with a loud and irritated roar (ie abnormal...).
Car is 1994 E500, 53K, Starmarked.
Thanks in advance

Last edited by fhmajid; 10-28-2001 at 07:26 PM.
Reply With Quote
Old 10-28-2001, 08:30 PM
Posts: n/a

Since you did not ask a questions, I'll take it that you are looking for some assistance in locating the possible cause of the stop lamps being always on.

Well since it is Starmarked..... take it to the dealer and have them look over the wiring. Chances are that the stop lamp switch on the brake pedal is causing the short.

The incident after the vacuum does not sound good.

Get to the dealer ASAP. You don't want to start seeing smoke rising up from under the dash.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help fighting traffic ticket. blau Open Discussion 35 01-16-2008 06:48 AM
Amber Fog Lamps (for $2) morgantruce Diesel Discussion 15 08-11-2005 11:36 PM
Faux e500 I did it and so can you aldedmon Tech Help 8 08-09-2001 01:14 PM
Faux e500 I did it and so can you aldedmon Detailing and Interior 0 08-08-2001 10:51 AM
C43 or E500, which is better Chiragp Performance Paddock 51 06-03-2000 08:37 AM

All times are GMT -4. The time now is 11:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page