Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-2009, 01:22 AM
amosfella's Avatar
Registered User
 
Join Date: Jun 2006
Location: Vulcan, AB, Canada
Posts: 787
AC question 99 S500

I was thinking about having a look at a 99 S500, and I was wondering how likely it would be to have the evap core problem. I dont' have any more info on the car to give. Just wondering about experiences....
__________________
All it takes for evil to prevail is for good men to stand by and do nothing.

Too many people tip toe through life, never attempting or doing anything great, hoping to make it safely to death... Bob Proctor

'95 S320 LWB
'87 300SDL
'04 E500 wagon 4matic
Reply With Quote
  #2  
Old 07-02-2009, 09:15 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
In the US the 1999 S500 was a W140.051 chassis, a/c leaks at evaporator are common place in that chassis.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 07-02-2009, 12:35 PM
amosfella's Avatar
Registered User
 
Join Date: Jun 2006
Location: Vulcan, AB, Canada
Posts: 787
I"m fairly familiar with the 140 chassis, as I have a 95 S320v and love it. What are some options on that car that usually go haywire and cause problems?? Things to look for??
__________________
All it takes for evil to prevail is for good men to stand by and do nothing.

Too many people tip toe through life, never attempting or doing anything great, hoping to make it safely to death... Bob Proctor

'95 S320 LWB
'87 300SDL
'04 E500 wagon 4matic
Reply With Quote
  #4  
Old 12-02-2009, 10:20 AM
Registered User
 
Join Date: Sep 2007
Posts: 52
Do a search on "W140"

It will tell you pretty much anything you want to know. If you are considering buying one - be sure and get one with FULL service records and one that has already had the evap. core replace PREFERABLY with one that is all copper - not the copper/aluminum crap that leaks again in 10 years.
Check electricals - esp. door closing assist, wiring harness (issues on '93 thru early '96 cars), rear suspension on S500 cars. AVOID the S600 unless you have deep pockets and/or a fat bank account.
I have been very satisfied with my S500 - of course I may live to eat those words. Average maintenance for me has been around $1500 a year.

Edit - Sorry, just saw that you have a W140 already.....
check oiler tubes on the '99 - valve train noise and/or lower oil pressure likely means the bottoms have blown out. Rear suspension is expensive to fix - nitrogen spheres are about $200 a piece and the valve is $375 - not sure about struts.

Last edited by benzguy1987; 12-02-2009 at 10:24 AM. Reason: Prior info.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page