Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-07-2001, 09:22 AM
Posts: n/a
Question 560 SEL '90 Cruise Control surges constantly

At any speed, once the cruise control is activated it starts surging as if someone is constantly playing with the accelerator. Anybody have ideas on what is causing this?
Reply With Quote
Old 11-07-2001, 09:38 AM
Registered User
Join Date: Jun 2000
Location: Tucson, Arizona, USA
Posts: 180
Try lubricating the throttle linkage first, but it is very likely the cruise control amp. Some people have successfully resoldered bad connections on the circuit board. Also, there are reputable companies that rebuild them. Removing the old one and installing the new one is a simple DIY project--search the archives for instructions on your model year. Cheers, Andrew Seidel.
86 560SEC
85 500SEC Lorinser
83 300D Turbo
75 240D
Reply With Quote
Old 11-10-2001, 01:26 PM
Registered User
Join Date: Aug 2001
Location: Florida
Posts: 270
have you recently replaced any tail light bulbs. Have read that this is a common problem as the cruise control uses that circuit and copper based light bulbs cause this . Read the thread located 4 or 5 posts above yours about the same problem.
Reply With Quote
Old 11-12-2001, 08:33 AM
Posts: n/a
560 SEL cruise control surges constantly

Thanks to everyone who had a suggestion to my problem. I replaced the back tail light bulb with genuine mercedes and it didn't fix the cruise problem. I will now try to locate the throttle linkage and lube that. If that doesn't work then I guess it is the CC amp that is the culprit.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Repair Greg in Oz Tech Help 0 02-29-2004 06:25 PM
82 300SD throttle linkage and cruise control waybomb Diesel Discussion 0 12-28-2002 05:52 PM
Cruise Control was working after changing amp, now quit working again airfoill Tech Help 3 01-17-2002 08:37 AM
Aftermarket cruise control Mercedes Man Diesel Discussion 4 10-10-2001 09:02 AM
1988 420 SEL Cruise Control not working bermuda Tech Help 1 04-08-2001 04:43 PM

All times are GMT -4. The time now is 11:30 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page