Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-10-2001, 09:53 AM
Registered User
 
Join Date: Jan 2001
Location: hutto,texas,78634
Posts: 204
Unhappy 92 190 2.6 just quit like you cut the key off

any ideas??? have hot battery, power seats, head lights, but no dash lights or start. help!!!! thanks. mark
__________________

85 300 sd 168k current driver
85 300 sd parts
81 380 sl 125k
84 190 d 160k just bought!
Reply With Quote
  #2  
Old 11-10-2001, 06:46 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Fuel pump relay??? Can you hear the fuel pump when you turn the key? No dash lights? Sounds like a fuse...did you check the fuse box?
__________________
J.H.
'86 300E
Reply With Quote
  #3  
Old 11-11-2001, 01:32 AM
Registered User
 
Join Date: Jan 2001
Location: hutto,texas,78634
Posts: 204
....no power of any kind to the switch, all fuses under the hood are good. ov relay seems good. im looking for a fusible link of some kind but dont know where to look.???
__________________

85 300 sd 168k current driver
85 300 sd parts
81 380 sl 125k
84 190 d 160k just bought!
Reply With Quote
  #4  
Old 11-12-2001, 01:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Have you had the starter or alternator replaced recently? If so, some of those multi-connector wires could be loose.

Also, there is one big connector on the back of the ignition switch.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #5  
Old 11-12-2001, 03:22 PM
Registered User
 
Join Date: Jan 2001
Location: hutto,texas,78634
Posts: 204
Unhappy 190 2.6.

thats my next check is the switch but its a pain to get to. everything under the hood looks ok. that seems to be the likely place being that nothing is going past that point. thanks. mark
__________________

85 300 sd 168k current driver
85 300 sd parts
81 380 sl 125k
84 190 d 160k just bought!
Reply With Quote
  #6  
Old 11-13-2001, 09:14 AM
Registered User
 
Join Date: Jan 2001
Location: hutto,texas,78634
Posts: 204
Smile

.....the plug had come loose from the back of the switch, all is well. thanks for all your help. mark
__________________

85 300 sd 168k current driver
85 300 sd parts
81 380 sl 125k
84 190 d 160k just bought!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190 E 2.6 Overvoltage Protection Relay Jnolee Tech Help 3 03-01-2000 02:17 PM
190 E 2.6 Throttle Cable Connection Jnolee Tech Help 1 09-14-1999 10:47 PM
Failed emissions 190 2.6 Jnolee Tech Help 4 09-03-1999 09:33 PM
190 e. 2.6 emissions fail Jnolee Tech Help 2 08-19-1999 10:56 PM
1989 190 E 2.6 Emissions jnolee Tech Help 1 05-23-1999 08:16 PM



All times are GMT -4. The time now is 08:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page