Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-15-2001, 01:10 AM
Verbeck
Guest
 
Posts: n/a
Defroster only blowing out cold air

I recently purchased 1979 300SD 116 Benz. My defroster will only blow out cold air, and warm air on the side vents. In the owners manual it says that the defroster should blow out warm air. Any suggestions on where I should look would be helpful. Thank you very much!


Candy Verbeck
Reply With Quote
  #2  
Old 11-15-2001, 02:18 AM
Steve019
Guest
 
Posts: n/a
Check your slide lever cable. If it is operational you may have to dig into the dash to find the problem. If you have warm air from the side vent you know your heater core is OK. Probably one of the interior doors that route the air.

Where is Keizer?
Reply With Quote
  #3  
Old 11-16-2001, 12:35 AM
Verbeck
Guest
 
Posts: n/a
Thank you very much for your info. Keizer is right by Salem in Oregon. Where is Broken Arrow at? Never heared of it. Thanks again!



Candy Verbeck
Reply With Quote
  #4  
Old 11-16-2001, 01:00 AM
Steve019
Guest
 
Posts: n/a
Broken Arrow is just S.E. of Tulsa, OK
Reply With Quote
  #5  
Old 11-25-2002, 09:30 PM
inturbidus
Guest
 
Posts: n/a
Hey Steve, I'm in Fayetteville, Arkansas. Small Mercedes World.
Reply With Quote
  #6  
Old 11-25-2002, 09:47 PM
fredddd
Guest
 
Posts: n/a
Had the same problem with my 82 SL. The auxiliary water pump wasn't working. I fixed it and now my defosters blow hot air. The side vent air is also much hotter than it was. Why one would be much warmer than the other, I don't know.
Hope this helps you,Don
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ML320 Intermittently Blowing Hot Air ScaryRaven ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 07-16-2004 04:59 PM
What Intake boot should I use for a cold air intake on my 300e??? mike690003 Performance Paddock 6 02-05-2004 02:28 AM
Cold Air Intake System Turbo][ Performance Paddock 4 01-21-2004 06:02 PM
300E AC stopped blowing cold air carcarwhite Tech Help 5 06-22-2003 09:18 PM
A/C air blowing out of defroster vents 300sdlguy Tech Help 3 05-13-1999 12:06 AM



All times are GMT -4. The time now is 02:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page