Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-30-2001, 03:04 PM
Posts: n/a
fuel system of 420sel

it seems after about 5-10 minutes of warming up and driving about a 1/2 mile, my fuel system is starving for fuel as i get on the interstate. but after a couple of minutes, it goes away. is it a fuel pump? do they warm up as well? keep in mind i'm in south dakota and it's getting cold
Reply With Quote
Old 11-30-2001, 06:43 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would start by looking at the coolant temp sensor. It is responsible for 50-60% of the fuel controll input on this system./
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
240D Top Speed ? Benz240D Diesel Discussion 73 07-04-2011 11:48 AM
Greasecar giving me pains... '80 300D driad_98 Diesel Discussion 14 07-14-2004 03:40 PM
Mechanical Fuel Injection Pump not working properly M_Anker Vintage Mercedes 12 06-06-2004 12:40 PM
Fuel line routing and banjo bolt help requested for two tank system Jimmy Joe Diesel Discussion 22 05-11-2004 01:46 AM
Basic fuel system bleeding TurboTurbine Tech Help 1 12-28-2001 04:11 AM

All times are GMT -4. The time now is 04:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page