Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-30-2001, 03:28 PM
Posts: n/a
Exclamation Injection Pump Problem

280SE 69'
The thermostat for the injection pump is not working correctly. The pin is stuck (about half way out), once it was freed the pin fell out. I have ordered a new T-stat.

I don't really under stand the whole arrangement or how it works. The pin has a bulb on the end of it so when the thermostat is heated the pin extends. The bulb prevents the pin from traveling through the tunnel. In the tunnel There is a keeper, which makes me think that the insert in the tunnel also moves, but is now frozen. Is this correct? Or is the pin supposed to travel all the way through to the pin on the other side?

Thanks for the help,

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Checklist: PS Pump Re-Seal EricSilver Tech Help 29 07-15-2007 11:35 AM
water pump problem on 560sl? sms Tech Help 0 07-02-2004 11:44 PM
Mechanical Fuel Injection Pump not working properly M_Anker Vintage Mercedes 12 06-06-2004 12:40 PM
Car smokes pretty bad under hard boost 87300SDLTurbo Tech Help 7 11-27-2002 04:47 AM
1975 240D How to Replace Diaphram on Injection Pump? Sfk35 Tech Help 1 04-08-2002 05:38 PM

All times are GMT -4. The time now is 11:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page