Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-01-2001, 10:27 PM
CEC CEC is offline
Registered User
Join Date: Dec 2001
Location: GA
Posts: 48
300TE Transmission Mount

After changing my motor mounts I tried to change the transmission mount. I can't get it off. The problem I have is the Flex Disk is in the way and I can't get any tools on the top nut of the mount. 1) What size is the nut? 2) How do I get it off with the Flex Disk in the way? The mount is falling apart so I have to change it. Car is up on jack stands so any quick advice would be great.

Reply With Quote
Old 12-02-2001, 12:07 AM
Registered User
Join Date: Dec 2000
Posts: 368
I'm pretty sure it's a 19mm nut. All you need is a wrench that has a slightly angled box end.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 S500 with 722.6 Automatic Transmission Filled for life? MBD Tech Help 29 07-30-2011 11:51 AM
300TE transmission slipping- help! derickson Tech Help 1 09-10-2004 12:25 AM
Stripped the Transmission mount bolts... PiP Diesel Discussion 6 08-22-2002 10:34 PM
Shake at Idle -> Possible solutions? Holson Adi Diesel Discussion 13 05-06-2002 12:39 AM

All times are GMT -4. The time now is 01:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page