PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   1991 300SE (http://www.peachparts.com/shopforum/tech-help/277393-1991-300se.html)

amc1324 05-13-2010 10:10 AM

1991 300SE
 
my car idles high and continues to pull when in Drive.

most of the time it idles ok and theres no problem.

when i put the pedal to the metal, it stutters for 2 seconds then accelerates normally. when i come to a stop the engine will keep pulling a little. ill put it in neutral and it will rev up to 3000rpm and sits there.

I have found somewhat of a solution. when its at 3000, i just rev it around 4000-5000 a few times and it will drop to 750(normal idle). my guess is something is sticking and im unsticking it by revving. IDK lol. help me

kiwi_bloke_nz 05-13-2010 10:37 PM

Im not sure about your model but I can speculate.

-Sticking ICV or lack of power to ICV.
-Sticking Throtle cable.

amc1324 05-14-2010 12:02 AM

ICV
 
I took off the ICV and sprayed 2+2 Carb Cleaner inside of it. filling it up and shaking it. i still havent gotten a hold of a volt meter tho.

I just wanna make sure its nothing else before i go and buy a new ICV. there like 200 bucks...

the throttle is not sticking at all. it always returns to its original position.

kiwi_bloke_nz 05-14-2010 06:03 AM

Could be a vaccum leak that changes with temperature.

I have struck ICV that have stuck open despite cleaning them. I would suggest swapping one from a good car.


All times are GMT -4. The time now is 07:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website