Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-12-2010, 02:09 PM
olpos's Avatar
Registered User
 
Join Date: Sep 2003
Location: san diego.ca.
Posts: 323
Question,Any bad water pump impellers on M104's

Going crazy with this C280 ,1997, that i bought with a bad radiator.109k miles on car.Plastic had burst neck did not break.Note there is no air in system,pretty good at bleeding these cars.
Put in new radiator,car almost overheated in about 10 miles.
Replaced thermostat ,Did over heat in about 1/2 mile.
Took out stat to test,over heat in less than 1/2 mile
Found coolant on number 6 plug.New head gasket and did head at same time.
Over heat in 1/2 mile.
Found new radiator only gets hot on hose side 210 degrees.
3/4 of radiator 100 degrees.
2nd new radiator SAME
If this was a vw or bmw with plastic impellers would have changed water pump with radiator,but these Benz water pumps don't seem to have impeller problems.
SO has anyone had a impeller problem on a M103 ORM104??.
Its getting a new pump next week at this point just wondering if this is just my luck or ??
Rich

__________________
88 300E White, sold 9-04
88 190E Black 2.3 sold
90 300CE White, Grey sold 12-24-04
92 400E White,Grey Sold 5-06
90 300CE 91K Signal Red,Black Sold 2007
1989 300CE Smoke silver,Tan Sold 1-08
1993 300E 3.2 M104 motor
1991 300CE White,Grey
1994 E420 beautiful car,gone to new home
1994 E320 Smoke an Parchment.Beautiful car
Reply With Quote
  #2  
Old 06-12-2010, 04:39 PM
Registered User
 
Join Date: Aug 2008
Posts: 436
I buy my pumps rebuilt at the dealer- never had a pump problem YET!

Are you bleeding the system of air?

M
Reply With Quote
  #3  
Old 06-12-2010, 06:30 PM
Registered User
 
Join Date: Oct 2006
Location: Southern NJ
Posts: 357
I just did the WP on my 123, and saw a variety of pumps to select. I purchased a Graf, Laso, also a good choice. It has a cast impeller, with swept back blades. Less cavitation, better design. AZ, and other chains had stamped straight blades, and so I stayed clear.

The Graf matched the OEM. I filled/drove 3X to get a filled system.

Good Luck,
__________________
Gary
Experience is something you get, Just after you needed it....
'99 E300 295K, '83 300D 220K, '75 240D 185K sold
'80 MCI Bus Conv DD 6V92TA, w/4 cyl. Kubota diesel GenSet 12.5KW
Reply With Quote
  #4  
Old 06-12-2010, 06:33 PM
Registered User
 
Join Date: Dec 2007
Location: NorCal
Posts: 1,332
Chances are that is the original water pump, so not necessarily a design flaw in the Benz pump, but it could just be worn out. Head gasket, new radiator, the only thing left is the WP.
__________________
http://i193.photobucket.com/albums/z...-RESIZED-1.jpg
1991 300E - 212K and rising fast...
Reply With Quote
  #5  
Old 06-12-2010, 11:54 PM
latief's Avatar
1993 300E 2.8- M104
 
Join Date: Aug 2009
Location: Gainesville, FL
Posts: 518
what brand radiator ?
__________________
1993 300E, 2.8 M104 .....
Reply With Quote
  #6  
Old 06-13-2010, 12:56 AM
Registered User
 
Join Date: Dec 2006
Location: beautiful Bucks Co, PA
Posts: 961
I don't know what would wear out on a water pump. The impeller doesn't contact anything but a seal, and if that goes bad you have a leak. You could remove and inspect it, that would cost little except your time.
I think you still have a head/headgasket issue.
Reply With Quote
  #7  
Old 06-13-2010, 06:26 AM
locry's Avatar
I love this place!!! :)
 
Join Date: Nov 2003
Location: Philippines, ...recently submerged, AGAIN
Posts: 1,020
is this the first time you're trying to run the car since purchase?
__________________

85 190E 2.3(SOLD)
86 230E (-->300D) sold
87 300D (-->300TD) sold
68 250S w/ a 615 and manual tranny (RIP)
87 300TD (SOLD)
95 S280 "The KRAKEN" (Turbo 2.9 602 transplant) traded
86 190E 2.3... current project
Reply With Quote
  #8  
Old 06-13-2010, 06:48 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,077
Rich, flush the cooling system to ensure all the passageways are clear. Buy a rebuilt water pump from your local MB dealer. Are you certain the temperature sender is giving an accurate coolant temperature?
__________________
Fred Hoelzle
Reply With Quote
  #9  
Old 06-13-2010, 10:44 AM
olpos's Avatar
Registered User
 
Join Date: Sep 2003
Location: san diego.ca.
Posts: 323
Well this was what i was looking for,so far no one has jumped on and said they have seen a bad impeller one one of these.On some cars these do break off,almost all of these are plastic water pumps.
What is throwing me off is there seems to be low coolant flow.Radiator only gets hot near the hose end of the radiator.
220 degrees on the drivers side of the radiator.Over 3/4 of radiator stays at about 100.used temp gun to verify.
Start the car,runs great,idle till normal hot,fans work,new fan clutch,drive car out of drive way and when thermostat opens temp gauge moves very fast to full overheat as only the 220 degree coolant goes into motor.almost like only the drivers side of radiator is circulating.This is verified with a temp gun.
2 new radiators,not behr but this brand works well in all other cars.
Before i put a new german water pump in i will use a 300e radiator i have to verify its not these after market radiators.
For those who use rebuilt water pumps,good luck.
These M104 water pumps are really hard to put in and rebuilts do not always work right.
to answer some other questions,no air in radiator,should have used a Benz radiator but did not.but next time it will be a Behr.Yes bought the car with bad radiator from an elderly lady that had it seviced at benz for every little thing.
Cooling system very clean,old coolant not burnt.
Runs very well but low coolant flow(????)
Will find out next week and follow up so someone else in this boat may find this and read this.
Rich
__________________
88 300E White, sold 9-04
88 190E Black 2.3 sold
90 300CE White, Grey sold 12-24-04
92 400E White,Grey Sold 5-06
90 300CE 91K Signal Red,Black Sold 2007
1989 300CE Smoke silver,Tan Sold 1-08
1993 300E 3.2 M104 motor
1991 300CE White,Grey
1994 E420 beautiful car,gone to new home
1994 E320 Smoke an Parchment.Beautiful car
Reply With Quote
  #10  
Old 06-13-2010, 10:47 AM
latief's Avatar
1993 300E 2.8- M104
 
Join Date: Aug 2009
Location: Gainesville, FL
Posts: 518
Overheating .. I give up

My experience with aftermarket ^^^^

I would just change it out on a temporary bases to eliminate any design issue
__________________
1993 300E, 2.8 M104 .....
Reply With Quote
  #11  
Old 06-19-2010, 12:41 PM
olpos's Avatar
Registered User
 
Join Date: Sep 2003
Location: san diego.ca.
Posts: 323
Well this cooling problem is done,and embarassing also.
Turns out thermostat was sticking closed.This new stat,puchased before head gasket repair was the culprit.
This part was pulled and checked 3 times.First before head gasket repair and it was open all the way.only ran it for about3 minuites ,did not boil coolant.
Second time after head repair it was open about half way when it was checked.OK for the temp of coolant at the time.
Third time it was slammed shut and also binding on the shaft really bad.
Took it out and ran without stat and car ran really cool.So bad stat.
Did put a new one in with Benz coolant and now runs just right/
So i wonder if it was closed when i checked it the second time and popped open when i unbolted the thermostat housing, fooling me into thinking it worked.
Well its done anyway.So the whole question here is do M103 AND M104'S have bad impellers.Looks to be NO.
Also i bought a new nissen radiator and it looks just like the aftermarket one.Looks to be from the same company.Thanks for all the help,Rich

__________________
88 300E White, sold 9-04
88 190E Black 2.3 sold
90 300CE White, Grey sold 12-24-04
92 400E White,Grey Sold 5-06
90 300CE 91K Signal Red,Black Sold 2007
1989 300CE Smoke silver,Tan Sold 1-08
1993 300E 3.2 M104 motor
1991 300CE White,Grey
1994 E420 beautiful car,gone to new home
1994 E320 Smoke an Parchment.Beautiful car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page