Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-16-2010, 02:04 PM
Registered User
 
Join Date: Jul 2004
Location: Annapolis, Md.
Posts: 556
02 E320 Wagon electric fan always runs

I have an 02 E320 Wagon that if the a/c is off and the engine has just been started on a cold start the fan pretty much immediately runs on high. When the ignition is shut off it does stop running.

Stuck relay, control module, temp. switch?? Any common causes?

Thanks!

__________________
-disav

99 E300 TURBODIESEL Astral Silver 282K - AMG brakes, suspension, monoblocks, speedo & interior - Full Load Maxed on IP by custom Speed Tuning USA Chip - T3/T4 Garrett - EGR/MAF delete
98 E300 TURBODIESEL Alexandrite Green on black leather 289K
95 E300 DIESEL Green Queen 267K SOLD
84 300D 216k SOLD
87 300D 299K #22 head - intercooler - full load adj. - 8sec 0-60mph - SOLD
76 300D 214K SOLD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page