PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   code issues (http://www.peachparts.com/shopforum/tech-help/279486-code-issues.html)

nucor 06-17-2010 02:58 AM

code issues
 
i have a 94 e420 these codes reappeared 4,6,17,19,20 can someone help me with them. [1] code 4 is dealing with oxygen sensor if iam correct just put a new one on the car about 2 weeks ago. [2] code 6 is dealing with the diagnostic module. [3] code 17 coolant i will check the ratio of antifreeze to water tommorow to see where it is at. [4] code 19 is dealing with a tapping noise which i here on the driver side. i have a valve covers set and i just changed oil 2 wks ago i used 10w30 mobil 1 but i still here tapping will pull valve cover this wkend n check the oil tubes. what is part # for chain tensioner clamp. [5] code viscous fan clutch. also my a/c started to blown warm air to day. i noticed a week or so ago that my window would have a mist or condensation on it will this be coming from low freon. any sugestion will really help please. temp here is around 90 plus degrees with high humidtyhttp://www.benzworld.org/forums/imag.../surrender.gifhttp://www.benzworld.org/forums/imag...s/confused.gif

deanyel 06-17-2010 09:26 AM

You're getting those codes where? It sounds like you have the wrong code list. The first thing to do is read all the pins/codes and get the right code lists.

Kestas 06-17-2010 09:32 AM

The link below contains a thread that links a 169 page pdf document that covers the codes for Mercedes models from 1988 to 1998. Go to the second post of the link below for the pdf attachment. It should have the proper codes for your model.

http://www.mbworld.org/forums/e-clas...ult-codes.html

I'd attach it here, but the file is too big to attach on this forum.

nucor 06-22-2010 07:53 PM

code issues
 
:)deanyel iam getting the codes from the little black box in the front of the 38 pin box it has the blinking light i counted the blinks from it

deanyel 06-22-2010 10:13 PM

The pushbutton/LED on the ancillary 8 pin plug is the DM / diagnostic module, which is also on pin 19 of the 38 pin. Look up the DM codes and other codes for a 124.034 at the link below:

http://www.motodok.com/Documentation/Files/MB/cs1000-mb.pdf

nucor 06-28-2010 04:00 PM

Quote:

Originally Posted by deanyel (Post 2492509)
The pushbutton/LED on the ancillary 8 pin plug is the DM / diagnostic module, which is also on pin 19 of the 38 pin. Look up the DM codes and other codes for a 124.034 at the link below:

http://www.motodok.com/Documentation/Files/MB/cs1000-mb.pdf

deanyel i check the codes on page 45,46 it state if i readed it right

20= ignition control module dtc memory faulty
19= ground, coding from left ezl/akr ignition control module not present
17= crank shaft position sensor faulty
6= camshaft position sensor faulty
4= load sensor in eal akr control module faulty


what do i need to do or did i ready it right. could some one help me with this issue

deanyel 06-28-2010 06:13 PM

Nope, still the wrong codes. It's on pages 35-36, and also here - http://www.startekinfo.com/manual/volumes/e3/8_1/m11.jsp Clear the codes, drive it a while and see what comes back.

nucor 07-01-2010 06:21 PM

code issues
 
Quote:

Originally Posted by deanyel (Post 2495791)
Nope, still the wrong codes. It's on pages 35-36, and also here - http://www.startekinfo.com/manual/volumes/e3/8_1/m11.jsp Clear the codes, drive it a while and see what comes back.

denyel
4 air injection inoperative would that have to deal with air sensor.
6 idle speed control
17 data exchange malfuntion between control modle
19 fuel injectors open/short self adaptation
20 speed signal would that have to deal with sensor on wheels

how do i fix theses problem 6,17,19 if i got 4, 20 right

deanyel 07-01-2010 09:38 PM

Quote:

Originally Posted by nucor (Post 2497697)
denyel
4 air injection inoperative would that have to deal with air sensor.
6 idle speed control
17 data exchange malfuntion between control modle
19 fuel injectors open/short self adaptation
20 speed signal would that have to deal with sensor on wheels

how do i fix theses problem 6,17,19 if i got 4, 20 right

Don't address your questions just to one person, you want lots of people to participate. Plus you could misspell that one person's name. But go to the Startekinfo site above, find the code, look in the right hand column for the 'remedy/test". It usually points to another step - which in this case is going to be to build the code reader and read the codes on the other diagnostic modules/pins. 4 is air pump related, maybe a vacuum hose. Idle speed control is a system, could be lots of thing, worst case is a throttle actuator. But next step is to build the 38 pin code reader.

400Eric 07-01-2010 10:07 PM

I find it hard to believe that so many things could be bad all at once. What kind of shape is the wire harness in? If the ECU is receiving bogus info from it's sensors because the harness is bad, it will start throwing codes.
Regards, Eric

nucor 07-07-2010 05:09 AM

code issues
 
Quote:

Originally Posted by deanyel (Post 2497794)
Don't address your questions just to one person, you want lots of people to participate. Plus you could misspell that one person's name. But go to the Startekinfo site above, find the code, look in the right hand column for the 'remedy/test". It usually points to another step - which in this case is going to be to build the code reader and read the codes on the other diagnostic modules/pins. 4 is air pump related, maybe a vacuum hose. Idle speed control is a system, could be lots of thing, worst case is a throttle actuator. But next step is to build the 38 pin code reader.

sorry about the mispelled name deanyel. your helping hand is very helpful i printed out the chart but havent had chance to check the or tried to fix. will try to fix or look at next weekend going out of town this week.

nucor 07-07-2010 05:12 AM

code issues
 
Quote:

Originally Posted by 400Eric (Post 2497810)
I find it hard to believe that so many things could be bad all at once. What kind of shape is the wire harness in? If the ECU is receiving bogus info from it's sensors because the harness is bad, it will start throwing codes.
Regards, Eric

hi eric those are the codes that it gave. i replaced the wire harness about a year ago


All times are GMT -4. The time now is 12:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website